Some minor notes about PGP interop.
authorRobert J. Hansen <rjh@sixdemonbag.org>
Fri, 20 Oct 2017 00:52:08 +0000 (20:52 -0400)
committerRobert J. Hansen <rjh@sixdemonbag.org>
Fri, 20 Oct 2017 00:52:08 +0000 (20:52 -0400)
web/faq/gnupg-faq.org

index 454b570..a0c5996 100644 (file)
@@ -203,6 +203,25 @@ Largely, yes.  It can be made to interoperate with anything from PGP
 5 and onwards, and has excellent interoperability with the most
 recent releases.
 
+*** Does it support Diffie-Hellman?
+:PROPERTIES:
+:CUSTOM_ID: pgp_dh
+:END:
+
+Yes.  “Diffie-Hellman” is what PGP calls the Elgamal encryption
+algorithm.  If your PGP-generated keypair uses a Diffie-Hellman
+encryption subkey, it will appear in GnuPG as an Elgamal subkey. The
+correct name, incidentally, is Elgamal.
+
+*** Does it support SHA-2-256 and SHA-2-512?
+:PROPERTIES:
+:CUSTOM_ID: pgp_sha2
+:END:
+
+Yes.  SHA-256 and SHA-512 belong to a group of hashes known
+collectively as “SHA-2”.  PGP calls SHA-256 and SHA-512 by the
+non-standard names “SHA-2-256” and “SHA-2-512”, but they are the same
+algorithms.
 
 ** Which operating systems does it run on?
    :PROPERTIES:
@@ -1822,7 +1841,6 @@ You can if you want, but it won’t make your private key any more
 secure.  Your private key is already encrypted: your passphrase is the
 key used to decrypt your private key.
 
-
 * Advanced topics
   :PROPERTIES:
   :CUSTOM_ID: advanced_topics