Do not use no-libgcrypt dummy for tools
authorWerner Koch <wk@gnupg.org>
Wed, 8 Jun 2016 07:17:49 +0000 (09:17 +0200)
committerWerner Koch <wk@gnupg.org>
Wed, 8 Jun 2016 07:17:49 +0000 (09:17 +0200)
commit173fa97102fec68670a46ae1b460231e2a183c81
tree7c5bfd3bced479039c5dab32aec68fcd3d9398a4
parent0faf8951544f43790c412777a926c969540174bd
Do not use no-libgcrypt dummy for tools

* tools/Makefile.am (gpgconf_SOURCES): Remove no-libgcrypt.c.
(gpgconf_LDADD): Add LIBGCRYPT_LIBS.
(gpg_connect_agent_LDADD): Ditto.
(gpgtar_LDADD): Ditto.
* dirmngr/Makefile.am (dirmngr_client_LDADD): Ditto.
(t_common_ldadd): Ditto.  Remove no-libgcrypt.o.
--

We need this change so that a future code in common/ can use Libgcrypt
functions; in particular hashing.

Signed-off-by: Werner Koch <wk@gnupg.org>
dirmngr/Makefile.am
tools/Makefile.am