Require libgpg-error 1.10
authorWerner Koch <wk@gnupg.org>
Fri, 20 May 2011 08:14:21 +0000 (10:14 +0200)
committerWerner Koch <wk@gnupg.org>
Fri, 20 May 2011 08:27:50 +0000 (10:27 +0200)
This allows to remove some error code substitutes.
Fixed a typo in gpg.text.

ChangeLog
common/ChangeLog
common/util.h
configure.ac
doc/gpg.texi

index 2118a1e..edd82ed 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2011-05-20  Werner Koch  <wk@g10code.com>
+
+       * configure.ac: Require libgpg-error 1.10.
+
 2011-03-08  Werner Koch  <wk@g10code.com>
 
        Release 2.1.0beta2.
index a68246e..d77fad5 100644 (file)
@@ -1,3 +1,7 @@
+2011-05-20  Werner Koch  <wk@g10code.com>
+
+       * util.h: Remove some error code substitutes.
+
 2011-04-25  Werner Koch  <wk@g10code.com>
 
        * userids.c (classify_user_id): Add arg OPENPGP_HACK to fix
index fc3dd02..45bccec 100644 (file)
 #include <errno.h>  /* We need errno.  */
 #include <gpg-error.h> /* We need gpg_error_t. */
 /* Add error codes available only in newer versions of libgpg-error.  */
-#ifndef GPG_ERR_MISSING_KEY
-#define GPG_ERR_MISSING_KEY 181
-#endif
-#ifndef GPG_ERR_LIMIT_REACHED
-#define GPG_ERR_LIMIT_REACHED 183
-#endif
-#ifndef GPG_ERR_NOT_INITIALIZED
-#define GPG_ERR_NOT_INITIALIZED 184
-#endif
-#ifndef GPG_ERR_MISSING_ISSUER_CERT
-#define GPG_ERR_MISSING_ISSUER_CERT 185
-#endif
 #ifndef GPG_ERR_NO_KEYSERVER
 #define GPG_ERR_NO_KEYSERVER 186
 #endif
-#ifndef GPG_ERR_FULLY_CANCELED
-#define GPG_ERR_FULLY_CANCELED 198
-#endif
 #ifndef GPG_ERR_INV_CURVE
 #define GPG_ERR_INV_CURVE 187
 #endif
index ab40c6f..c7be7f7 100644 (file)
@@ -40,7 +40,7 @@ AC_INIT([gnupg],
 # sufficient.
 development_version=no
 
-NEED_GPG_ERROR_VERSION=1.8
+NEED_GPG_ERROR_VERSION=1.10
 
 NEED_LIBGCRYPT_API=1
 NEED_LIBGCRYPT_VERSION=1.5.0
index 0ed8c4e..c505e07 100644 (file)
@@ -2510,7 +2510,7 @@ timestamp issues on subkeys.
 @item --ignore-valid-from
 GnuPG normally does not select and use subkeys created in the future.
 This option allows the use of such keys and thus exhibits the
-pre-1.0.7 behaviour. You should not use this option unless you there
+pre-1.0.7 behaviour. You should not use this option unless there
 is some clock problem. See also @option{--ignore-time-conflict} for timestamp
 issues with signatures.