Add missing patch for kxmlgui
authorAndre Heinecke <aheinecke@gnupg.org>
Mon, 11 Mar 2019 15:06:12 +0000 (16:06 +0100)
committerAndre Heinecke <aheinecke@gnupg.org>
Mon, 11 Mar 2019 15:06:12 +0000 (16:06 +0100)
* patches/kxmlgui/0001-make-qdbus-optional.patch: New.

Makefile.am
patches/kxmlgui/0001-make-qdbus-optional.patch [new file with mode: 0755]

index 3b1e085..d827e09 100644 (file)
@@ -35,6 +35,7 @@ EXTRA_DIST = autogen.sh README.GIT ONEWS \
         patches/kiconthemes/0001-Make-DBus-optional.patch \
         patches/kleopatra/0005-Hack-generated-conf-files-for-Crosscompiling.patch \
         patches/kleopatra/fix-qt5.6-build.patch \
+        patches/kxmlgui/0001-make-qdbus-optional.patch \
         patches/kxmlgui/0003-Make-KTextWidgets-optional.patch \
         patches/kxmlgui/0004-Cruedly-disable-KSendbugmail.patch \
         patches/libgpg-error-1.29/0001-doc-Fix-yat2m-build-for-cross-compilation.patch \
diff --git a/patches/kxmlgui/0001-make-qdbus-optional.patch b/patches/kxmlgui/0001-make-qdbus-optional.patch
new file mode 100755 (executable)
index 0000000..1b10d05
--- /dev/null
@@ -0,0 +1,14 @@
+#! /bin/sh
+patch -p0 -l -f $* < $0
+exit $?
+
+--- CMakeLists.txt.orig 2019-02-18 17:01:11.892790831 +0100
++++ CMakeLists.txt      2019-02-18 17:05:04.381951901 +0100
+@@ -37,7 +37,7 @@
+ # Dependencies
+ set(REQUIRED_QT_VERSION 5.10.0)
+ find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED Widgets Xml Network PrintSupport)
+-if (NOT ANDROID)
++if (NOT ANDROID AND NOT WIN32)
+   find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED DBus)
+ endif()