Change the various version numbers to the new scheme.
authorWerner Koch <wk@gnupg.org>
Tue, 26 Feb 2013 16:10:18 +0000 (17:10 +0100)
committerWerner Koch <wk@gnupg.org>
Tue, 26 Feb 2013 16:10:18 +0000 (17:10 +0100)
commitd8b46c919f45666af0d541e00dcedf57e6c4b66f
tree7f07e8e93a55790df77ae6839fc32aebb4200198
parent863c0f2a3eaf2a5d46c5518e5ac3486cc1a49bd3
Change the various version numbers to the new scheme.

* configure.ac: Rename my_foo variables to mym4_foo variables to make
clear that they are processed by m4.
(VERSION_NUMBER): New ac_subst.
(AH_BOTTOM): Add CRIGHTBLURB macro.
(BUILD_REVISION, BUILD_FILEVERSION, BUILD_TIMESTAMP): Change them to
work similar to libgpg-error et al.
* src/versioninfo.rc.in: Remove use of BUILD_NUMBER and get it in line
with gpg-error et al.
* src/version.c (cright_blurb): New.
(gpgme_check_version_internal): Add magic to display the above
information.
* tests/t-version.c (main): Add option --verbose.
configure.ac
src/version.c
src/versioninfo.rc.in
tests/t-version.c