python: Skip tests if running with GnuPG < 2.1.12.
authorJustus Winter <justus@g10code.com>
Mon, 27 Mar 2017 09:11:47 +0000 (11:11 +0200)
committerJustus Winter <justus@g10code.com>
Mon, 27 Mar 2017 09:11:47 +0000 (11:11 +0200)
* lang/python/tests/support.py (assert_gpg_version): Fix error
message.  Skip all tests when we use GnuPG older than 2.1.12.

GnuPG-bug-id: 3008
Signed-off-by: Justus Winter <justus@g10code.com>
lang/python/tests/support.py

index 680300c..fabd818 100644 (file)
@@ -32,9 +32,14 @@ def assert_gpg_version(version=(2, 1, 0)):
         clean_version = re.match(r'\d+\.\d+\.\d+', c.engine_info.version).group(0)
         if tuple(map(int, clean_version.split('.'))) < version:
             print("GnuPG too old: have {0}, need {1}.".format(
-                c.engine_info.version, '.'.join(version)))
+                c.engine_info.version, '.'.join(map(str, version))))
             sys.exit(77)
 
+# Skip the Python tests for GnuPG < 2.1.12.  Prior versions do not
+# understand the command line flags that we assume exist.  C.f. issue
+# 3008.
+assert_gpg_version((2, 1, 12))
+
 # known keys
 alpha = "A0FF4590BB6122EDEF6E3C542D727CC768697734"
 bob = "D695676BDCEDCC2CDD6152BCFE180B1DA9E3B0B2"