Does now compile under MingW32/CPD 0.3
authorWerner Koch <wk@gnupg.org>
Thu, 18 Jan 2001 09:11:49 +0000 (09:11 +0000)
committerWerner Koch <wk@gnupg.org>
Thu, 18 Jan 2001 09:11:49 +0000 (09:11 +0000)
ChangeLog
autogen.sh
build-w32 [deleted file]
configure.in
gpgme/gpgme.c
gpgme/gpgme.h

index e69de29..f11e6da 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -0,0 +1,4 @@
+2001-01-18  Werner Koch  <wk@gnupg.org>
+
+       * autogen.sh: Added option --build-w32.
+
index 11b2761..a386bb0 100755 (executable)
@@ -3,27 +3,27 @@
 # It is only needed for the CVS version.
 
 PGM=GPGME
-DIE=no
+lib_config_files=""
+autoconf_vers=2.13
+automake_vers=1.4
+aclocal_vers=1.4
+libtool_vers=1.3
 
-#
-# Use --build-w32 to prepare the cross compiling build for Windoze
-#
+DIE=no
 if test "$1" = "--build-w32"; then
     shift
     target=i386--mingw32
+    if [ ! -f ./config.guess ]; then
+        echo "./config.guess not found" >&2
+        exit 1
+    fi
     host=`./config.guess`
         
-    CC="${target}-gcc"
-    CPP="${target}-gcc -E"
-    RANLIB="${target}-ranlib"
-        
-    cc_version=`$CC --version`
-    if ! echo "$cc_version" | egrep '[0-9]+wk[0-9]+' ; then
-        echo "gcc version $cc_version is not supported" >&2
-        echo "see doc/README.W32 for instructions" >&2
+    if ! mingw32 --version >/dev/null; then
+        echo "We need at least version 0.3 of MingW32/CPD" >&2
         exit 1
     fi
-        
+
     if [ -f config.h ]; then
         if grep HAVE_DOSISH_SYSTEM config.h | grep undef >/dev/null; then
             echo "Pease run a 'make distclean' first" >&2
@@ -31,16 +31,35 @@ if test "$1" = "--build-w32"; then
         fi
     fi
 
-    export CC CPP RANLIB
-    ./configure --host=${host} --target=${target} $*
+    crossbindir=`mingw32 --install-dir`/bin
+    CC=`mingw32 --get-path gcc`
+    CPP=`mingw32 --get-path cpp`
+    AR=`mingw32 --get-path ar`
+    RANLIB=`mingw32 --get-path ranlib`
+    export CC CPP AR RANLIB 
+
+    disable_foo_tests=""
+    if [ -n "$lib_config_files" ]; then
+        for i in $lib_config_files; do
+            j=`echo $i | tr '[a-z-]' '[A-Z_]'`
+            eval "$j=${crossbindir}/$i"
+            export $j
+            disable_foo_tests="$disable_foo_tests --disable-`echo $i| \
+                           sed 's,-config$,,'`-test"
+            if [ ! -f "${crossbindir}/$i" ]; then                   
+                echo "$i not installed for MingW32" >&2
+                DIE=yes
+            fi
+        done
+    fi
+    [ $DIE = yes ] && exit 1
+
+    ./configure --host=${host} --target=${target} \
+                ${disable_foo_tests} $*
     exit $?
 fi
 
 
-autoconf_vers=2.13
-automake_vers=1.4
-aclocal_vers=1.4
-libtool_vers=1.3
 
 if (autoconf --version) < /dev/null > /dev/null 2>&1 ; then
     if (autoconf --version | awk 'NR==1 { if( $3 >= '$autoconf_vers') \
diff --git a/build-w32 b/build-w32
deleted file mode 100755 (executable)
index bb72045..0000000
--- a/build-w32
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh
-
-target=i386--mingw32
-host=`./config.guess`
-
-CC="${target}-gcc"
-CPP="${target}-gcc -E"
-RANLIB="${target}-ranlib"
-
-export CC CPP RANLIB
-./configure --host=${host} --target=${target} $*
index 839ca82..79239a7 100644 (file)
@@ -13,7 +13,7 @@ AM_MAINTAINER_MODE
 #    AGE, set REVISION to 0.
 # 3. Interfaces removed (BAD, breaks upward compatibility): Increment
 #    CURRENT, set AGE and REVISION to 0.
-AM_INIT_AUTOMAKE(gpgme,0.1.4)
+AM_INIT_AUTOMAKE(gpgme,0.1.4a)
 LIBGPGME_LT_CURRENT=2
 LIBGPGME_LT_AGE=2
 LIBGPGME_LT_REVISION=0
index 10bdd8a..aea18fa 100644 (file)
@@ -176,7 +176,7 @@ gpgme_set_textmode ( GpgmeCtx c, int yes )
 void
 gpgme_set_keylist_mode ( GpgmeCtx c, int mode )
 {
-    if (c)
+    if (!c)
         return;
     c->keylist_mode = mode;
 }
index 57e0130..0fe59f7 100644 (file)
@@ -42,7 +42,7 @@ extern "C" {
  * let autoconf (using the AM_PATH_GPGME macro) check that this
  * header matches the installed library.
  * Warning: Do not edit the next line.  configure will do that for you! */
-#define GPGME_VERSION "0.1.4"
+#define GPGME_VERSION "0.1.4a"