Set next version to 1.10.0
authorWerner Koch <wk@gnupg.org>
Thu, 24 Aug 2017 14:19:54 +0000 (16:19 +0200)
committerWerner Koch <wk@gnupg.org>
Thu, 24 Aug 2017 14:20:51 +0000 (16:20 +0200)
--

NEWS
configure.ac
src/engine-gpg.c

diff --git a/NEWS b/NEWS
index f3394a2..25552ad 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,21 +1,22 @@
-Noteworthy changes in version 1.9.1 (unreleased)
-------------------------------------------------
+Noteworthy changes in version 1.10.0 (unreleased)
+-------------------------------------------------
 
  * Interface changes relative to the 1.9.0 release:
  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-
- gpgme_decrypt_result_t EXTENDED: New field 'is_de_vs'.
- gpgme_signature_t      EXTENDED: New field 'is_de_vs'.
- gpgme_op_delete_ext    NEW
- gpgme_op_delete_ext_start NEW
- GPGME_DELETE_ALLOW_SECRET NEW
- GPGME_DELETE_FORCE     NEW
- gpgme_op_conf_dir      NEW
+ gpgme_decrypt_result_t      EXTENDED: New field 'is_de_vs'.
+ gpgme_signature_t           EXTENDED: New field 'is_de_vs'.
+ gpgme_keyorg_t              NEW.
+ gpgme_op_delete_ext         NEW.
+ gpgme_op_delete_ext_start   NEW.
+ GPGME_DELETE_ALLOW_SECRET   NEW.
+ GPGME_DELETE_FORCE          NEW.
+ gpgme_op_conf_dir           NEW.
  cpp: DecryptionResult::isDeVs NEW.
  cpp: Signature::isDeVs        NEW.
- py: DecryptResult EXTENDED: New boolean field 'is_de_vs'.
- py: Signature     EXTENDED: New boolean field 'is_de_vs'.
- py: GpgError      EXTENDED: Partial results in 'results'.
+ py: DecryptResult           EXTENDED: New boolean field 'is_de_vs'.
+ py: Signature               EXTENDED: New boolean field 'is_de_vs'.
+ py: GpgError                EXTENDED: Partial results in 'results'.
+
 
 Noteworthy changes in version 1.9.0 (2017-03-28)
 ------------------------------------------------
@@ -44,7 +45,6 @@ Noteworthy changes in version 1.9.0 (2017-03-28)
 
  * Many smaller bug fixes.
 
-
  * Interface changes relative to the 1.8.0 release:
  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
  gpgme_op_createkey          CHANGED: Meaning of 'expire' parameter.
index b4878cc..1284317 100644 (file)
@@ -28,8 +28,8 @@ min_automake_version="1.14"
 # commit and push so that the git magic is able to work.  See below
 # for the LT versions.
 m4_define(mym4_version_major, [1])
-m4_define(mym4_version_minor, [9])
-m4_define(mym4_version_micro, [1])
+m4_define(mym4_version_minor, [10])
+m4_define(mym4_version_micro, [0])
 
 # Below is m4 magic to extract and compute the revision number, the
 # decimalized short revision number, a beta version string, and a flag
index bc60d82..9c0d7f7 100644 (file)
@@ -1874,7 +1874,7 @@ gpg_encrypt (void *engine, gpgme_key_t recp[], gpgme_encrypt_flags_t flags,
 
   if (!err && (flags & GPGME_ENCRYPT_WRAP))
     {
-      /* gpg is current not abale to detect already compressed
+      /* gpg is current not able to detect already compressed
        * packets.  Thus when using
        *   gpg --unwrap -d | gpg --no-literal -e
        * the encryption would add an additional compression layer.