2009-06-18 Marcus Brinkmann <marcus@g10code.de>
authorMarcus Brinkmann <mb@g10code.com>
Thu, 18 Jun 2009 17:16:47 +0000 (17:16 +0000)
committerMarcus Brinkmann <mb@g10code.com>
Thu, 18 Jun 2009 17:16:47 +0000 (17:16 +0000)
* configure.ac (my_version): Set to 1.2.0.
(LIBGPGME_LT_CURRENT, LIBGPGME_LT_AGE): Bump.
(LIBGPGME_LT_REVISION): Reset.

ChangeLog
NEWS
configure.ac

index 886249b..6be60e4 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+2009-06-18  Marcus Brinkmann  <marcus@g10code.de>
+
+       * configure.ac (my_version): Set to 1.2.0.
+       (LIBGPGME_LT_CURRENT, LIBGPGME_LT_AGE): Bump.
+       (LIBGPGME_LT_REVISION): Reset.
+
 2009-05-05  Marcus Brinkmann  <marcus@g10code.de>
 
        * configure.ac: Add infrastructure for compile time check of
diff --git a/NEWS b/NEWS
index 449dcbf..6b967f3 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,4 +1,4 @@
-Noteworthy changes in version 1.2.0 (unreleased)
+Noteworthy changes in version 1.2.0 (2009-06-18)
 ------------------------------------------------
 
  * New encryption flag GPGME_ENCRYPT_NO_ENCRYPT_TO to disable default
index f02ca8b..fd17cae 100644 (file)
@@ -31,8 +31,8 @@ min_automake_version="1.10"
 # specific feature can already be done under the assumption that the
 # SVN version is the most recent one in a branch.  To disable the SVN
 # version for the real release, set the my_issvn macro to no.
-m4_define(my_version, [1.1.9])
-m4_define(my_issvn, [yes])
+m4_define(my_version, [1.2.0])
+m4_define(my_issvn, [no])
 
 m4_define([svn_revision], m4_esyscmd([echo -n $( (svn info 2>/dev/null \
             || echo 'Revision: 0')|sed -n '/^Revision:/ {s/[^0-9]//gp;q;}')]))
@@ -47,11 +47,11 @@ AC_INIT([gpgme],
 #   (Interfaces added:                 AGE++)
 #   (Interfaces removed/changed:       AGE=0)
 #
-LIBGPGME_LT_CURRENT=17
+LIBGPGME_LT_CURRENT=18
 # Subtract 2 from this value if you want to make the LFS transition an
 # ABI break.  [Note to self: Remove this comment with the next regular break.]
-LIBGPGME_LT_AGE=6
-LIBGPGME_LT_REVISION=6
+LIBGPGME_LT_AGE=7
+LIBGPGME_LT_REVISION=0`
 
 # If the API is changed in an incompatible way: increment the next counter.
 GPGME_CONFIG_API_VERSION=1