Require libgpg-error 1.24 and libassuan 2.4.2
authorWerner Koch <wk@gnupg.org>
Tue, 12 Dec 2017 11:12:47 +0000 (12:12 +0100)
committerWerner Koch <wk@gnupg.org>
Tue, 12 Dec 2017 11:12:47 +0000 (12:12 +0100)
* src/util.h (GPG_ERR_FALSE): Remove due to newer libgpg-error.
--

We require these over one year old versions to better allign with
GnuPG's demand.  Note that the required libassuan is acgtually 2 years
old.

Signed-off-by: Werner Koch <wk@gnupg.org>
configure.ac
src/util.h

index be06d94..bca7bbf 100644 (file)
@@ -74,9 +74,9 @@ LIBQGPGME_LT_REVISION=0
 GPGME_CONFIG_API_VERSION=1
 ##############################################
 
-NEED_GPG_ERROR_VERSION=1.17
+NEED_GPG_ERROR_VERSION=1.24
 NEED_LIBASSUAN_API=2
-NEED_LIBASSUAN_VERSION=2.0.2
+NEED_LIBASSUAN_VERSION=2.4.2
 
 
 PACKAGE=$PACKAGE_NAME
index fd22d75..b4043ed 100644 (file)
 \f
 #define DIM(v) (sizeof(v)/sizeof((v)[0]))
 
-#if GPG_ERROR_VERSION_NUMBER < 0x011500 /* 1.21 */
-# define GPG_ERR_FALSE 256
-#endif
-
 #if GPG_ERROR_VERSION_NUMBER < 0x011900 /* 1.25 */
 # define GPG_ERR_ENGINE_TOO_OLD 300
 # define GPG_ERR_TOO_OLD        308