23cb5bd0d6cf0fe585c22c3befc34d028dfd14e0
[libgcrypt.git] / scripts / autogen.sh
1 #!/bin/sh
2 # Run this to generate all the initial makefiles, etc.
3
4 PGM=GnuPG
5 DIE=no
6
7 autoconf_vers=2.13
8 automake_vers=1.4
9 aclocal_vers=1.4
10 libtool_vers=1.3
11
12 if (autoconf --version) < /dev/null > /dev/null 2>&1 ; then
13     if (autoconf --version | awk 'NR==1 { if( $3 >= '$autoconf_vers') \
14                                exit 1; exit 0; }');
15     then
16        echo "**Error**: "\`autoconf\'" is too old."
17        echo '           (version ' $autoconf_vers ' or newer is required)'
18        DIE="yes"
19     fi
20 else
21     echo
22     echo "**Error**: You must have "\`autoconf\'" installed to compile $PGM."
23     echo '           (version ' $autoconf_vers ' or newer is required)'
24     DIE="yes"
25 fi
26
27 if (automake --version) < /dev/null > /dev/null 2>&1 ; then
28   if (automake --version | awk 'NR==1 { if( $4 >= '$automake_vers') \
29                              exit 1; exit 0; }');
30      then
31      echo "**Error**: "\`automake\'" is too old."
32      echo '           (version ' $automake_vers ' or newer is required)'
33      DIE="yes"
34   fi
35   if (aclocal --version) < /dev/null > /dev/null 2>&1; then
36     if (aclocal --version | awk 'NR==1 { if( $4 >= '$aclocal_vers' ) \
37                                                 exit 1; exit 0; }' );
38     then
39       echo "**Error**: "\`aclocal\'" is too old."
40       echo '           (version ' $aclocal_vers ' or newer is required)'
41       DIE="yes"
42     fi
43   else
44     echo
45     echo "**Error**: Missing "\`aclocal\'".  The version of "\`automake\'
46     echo "           installed doesn't appear recent enough."
47     DIE="yes"
48   fi
49 else
50     echo
51     echo "**Error**: You must have "\`automake\'" installed to compile $PGM."
52     echo '           (version ' $automake_vers ' or newer is required)'
53     DIE="yes"
54 fi
55
56
57 if (gettext --version </dev/null 2>/dev/null | awk 'NR==1 { split($4,A,"\."); \
58     X=10000*A[1]+100*A[2]+A[3]; echo X; if( X >= 1035 ) exit 1; exit 0}')
59     then
60     echo "**Error**: You must have "\`gettext\'" installed to compile $PGM."
61     echo '           (version 0.10.35 or newer is required; get'
62     echo '            ftp://alpha.gnu.org/gnu/gettext-0.10.35.tar.gz'
63     echo '            or install the latest Debian package)'
64     DIE="yes"
65 fi
66
67
68 if (libtool --version) < /dev/null > /dev/null 2>&1 ; then
69     if (libtool --version | awk 'NR==1 { if( $4 >= '$libtool_vers') \
70                                exit 1; exit 0; }');
71     then
72        echo "**Error**: "\`libtool\'" is too old."
73        echo '           (version ' $libtool_vers ' or newer is required)'
74        DIE="yes"
75     fi
76 else
77     echo
78     echo "**Error**: You must have "\`libtool\'" installed to compile $PGM."
79     echo '           (version ' $libtool_vers ' or newer is required)'
80     DIE="yes"
81 fi
82
83
84 if test "$DIE" = "yes"; then
85     exit 1
86 fi
87
88 echo "Running gettextize...  Ignore non-fatal messages."
89 echo "no" | gettextize --force
90 echo "Running libtoolize...  Ignore non-fatal messages."
91 echo "no" | libtoolize
92
93
94 echo "Running aclocal..."
95 aclocal
96 echo "Running autoheader..."
97 autoheader
98 echo "Running automake --gnu ..."
99 automake --gnu;
100 echo "Running autoconf..."
101 autoconf
102
103 echo "You can now run \"./configure\" and then \"make\"."
104