mpi: Suppress newer gcc warnings.
authorWerner Koch <wk@gnupg.org>
Fri, 30 Aug 2013 15:56:35 +0000 (17:56 +0200)
committerWerner Koch <wk@gnupg.org>
Wed, 4 Sep 2013 09:25:06 +0000 (11:25 +0200)
commit8698530b2f9ef95542f1dd550961de7af86cc256
tree4f389d0931e7ee327895102ba2e5128434167300
parentb28b1f732e1b4f9c62a9de87c22c6bb0d3f8fdb8
mpi: Suppress newer gcc warnings.

* src/g10lib.h (GCC_ATTR_UNUSED): Define for gcc >= 3.5.
* mpi/mpih-div.c (_gcry_mpih_mod_1, _gcry_mpih_divmod_1): Mark dummy
as unused.
* mpi/mpi-internal.h (UDIV_QRNND_PREINV): Mark _ql as unused.
--

Due to the use of macros and longlong.h, we use variables which are
only used by some architectures.  At least gcc 4.7.2 prints new
warnings abot set but not used variables.  This patch silences them.

Signed-off-by: Werner Koch <wk@gnupg.org>
mpi/mpi-internal.h
mpi/mpih-div.c
src/g10lib.h