Snapshot release 0.4.2 V0-4-2
authorWerner Koch <wk@gnupg.org>
Sun, 18 Oct 1998 15:21:20 +0000 (15:21 +0000)
committerWerner Koch <wk@gnupg.org>
Sun, 18 Oct 1998 15:21:20 +0000 (15:21 +0000)
README
scripts/autogen.sh

diff --git a/README b/README
index 823cc52..9b81722 100644 (file)
--- a/README
+++ b/README
     please subscribe before posting, see above (~line 33)).
 
 
     please subscribe before posting, see above (~line 33)).
 
 
-    Supported targets:
-    ------------------
-      powerpc-unknown-linux-gnu  (linuxppc)
-      hppa1.1-hp-hpux10.20
-
-
-
-
index 215ef07..17905a1 100755 (executable)
@@ -2,34 +2,32 @@
 # Run this to generate all the initial makefiles, etc.
 
 PGM=GnuPG
 # Run this to generate all the initial makefiles, etc.
 
 PGM=GnuPG
-
 DIE=no
 DIE=no
-NO_AUTOMAKE=no
 
 
-(autoconf --version) < /dev/null > /dev/null 2>&1 || {
+if (autoconf --version) < /dev/null > /dev/null 2>&1 ; then
+    :
+else
     echo
     echo "**Error**: You must have "\`autoconf\'" installed to compile $PGM."
     echo '           (version 2.10 or newer is required'
     echo
     echo "**Error**: You must have "\`autoconf\'" installed to compile $PGM."
     echo '           (version 2.10 or newer is required'
-    DIE=yes
-}
-
-(automake --version) < /dev/null > /dev/null 2>&1 || {
-    echo
-    echo "**Error**: You must have "\`automake\'" installed to compile $PGM."
-    echo '           (version 1.3 or newer is required)'
-    DIE=yes
-    NO_AUTOMAKE=yes
-}
-
+    DIE="yes"
+fi
 
 
-# if no automake, don't bother testing for aclocal
-test "$NO_AUTOMAKE" = "no" \
-     || (aclocal --version) < /dev/null > /dev/null 2>&1 || {
+if (automake --version) < /dev/null > /dev/null 2>&1 ; then
+  if (aclocal --version) < /dev/null > /dev/null 2>&1; then
+    :
+  else
     echo
     echo "**Error**: Missing "\`aclocal\'".  The version of "\`automake\'
     echo "           installed doesn't appear recent enough."
     echo
     echo "**Error**: Missing "\`aclocal\'".  The version of "\`automake\'
     echo "           installed doesn't appear recent enough."
-    DIE=yes
-}
+    DIE="yes"
+  fi
+else
+    echo
+    echo "**Error**: You must have "\`automake\'" installed to compile $PGM."
+    echo '           (version 1.3 or newer is required)'
+    DIE="yes"
+fi
 
 if test "$DIE" = "yes"; then
     exit 1
 
 if test "$DIE" = "yes"; then
     exit 1