Release 1.6.0. libgcrypt-1.6.0
authorWerner Koch <wk@gnupg.org>
Mon, 16 Dec 2013 16:38:55 +0000 (17:38 +0100)
committerWerner Koch <wk@gnupg.org>
Mon, 16 Dec 2013 16:39:09 +0000 (17:39 +0100)
NEWS
README
compat/compat.c
configure.ac

diff --git a/NEWS b/NEWS
index 978047f..48f8a21 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,4 +1,4 @@
-Noteworthy changes in version 1.6.0 (unreleased)
+Noteworthy changes in version 1.6.0 (2013-12-16)
 ------------------------------------------------
 
  * Removed the long deprecated gcry_ac interface.  Thus Libgcrypt is
@@ -12,6 +12,9 @@ Noteworthy changes in version 1.6.0 (unreleased)
 
  * Removed deprecated control codes.
 
+ * Improved performance of most cipher algorithms as well as for the
+   SHA family of hash functions.
+
  * Added support for the IDEA cipher algorithm.
 
  * Added support for the Salsa20 and reduced Salsa20/12 stream ciphers.
@@ -48,6 +51,8 @@ Noteworthy changes in version 1.6.0 (unreleased)
 
  * Added a feature to globally disable selected hardware features.
 
+ * Added debug helper functions.
+
  * Interface changes relative to the 1.5.0 release:
  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
  gcry_ac_*                      REMOVED.
diff --git a/README b/README
index 558e008..43f9094 100644 (file)
--- a/README
+++ b/README
@@ -3,6 +3,8 @@
                              Version 1.6
 
        Copyright (C) 1989,1991-2012 Free Software Foundation, Inc.
+       Copyright (C) 2012-2013 g10 Code GmbH
+       Copyright (C) 2013 Jussi Kivilinna
 
     Libgcrypt is free software.  See the file AUTHORS for full copying
     notices, and LICENSES for notices about contributions that require
@@ -33,7 +35,7 @@
     You should get the latest versions of course.
 
     After building and installing the libgpg-error package, you may
-    continue with Libgcrypt installation As with allmost all GNU
+    continue with Libgcrypt installation as with allmost all GNU
     packages, you just have to do
 
        ./configure
     actual terms.  The helper programs (e.g. gcryptrnd and getrandom)
     as well as the documentation are distributed under the terms of
     the GNU General Public License (GPL); see the file COPYING for the
-    actual terms.
+    actual terms.  The file LICENSES has notices about contributions
+    that require these additional notices are distributed.
 
     This library used to be available under the GPL - this was changed
     with version 1.1.7 with the rationale that there are now many free
     Commercial grade support for Libgcrypt is available; please see
     http://www.gnupg.org/service.html .
 
+    Commercial grade support for Libgcrypt is available; for a listing
+    of offers see http://www.gnupg.org/service.html .  The driving
+    force behind the development of Libgcrypt is the company of its
+    principal author, Werner Koch.  Maintenance and improvement of
+    Libgcrypt takes up a lot resources.  To allow him to continue his
+    work, he asks to either purchase a support contract, engage them
+    for custom enhancements, or to donate money.  See http://g10code.com .
+
 
   This file is Free Software; as a special exception the authors gives
   unlimited permission to copy and/or distribute it, with or without
index d259130..5678067 100644 (file)
 const char *
 _gcry_compat_identification (void)
 {
+  /* For complete list of copyright holders see the file AUTHORS in
+     the source distribution.  */
   static const char blurb[] =
     "\n\n"
     "This is Libgcrypt " PACKAGE_VERSION " - The GNU Crypto Library\n"
-    "Copyright 2000, 2002, 2003, 2004, 2007, 2008, 2009,\n"
-    "          2010, 2011, 2012 Free Software Foundation, Inc.\n"
-    "Copyright 2012, 2013 g10 Code GmbH\n"
+    "Copyright (C) 2000-2012 Free Software Foundation, Inc.\n"
+    "Copyright (C) 2012-2013 g10 Code GmbH\n"
+    "Copyright (C) 2013 Jussi Kivilinna\n"
     "\n"
     "(" BUILD_REVISION " " BUILD_TIMESTAMP ")\n"
     "\n\n";
index 571e156..66c3120 100644 (file)
@@ -54,15 +54,15 @@ AC_INIT([libgcrypt],[mym4_full_version],[http://bugs.gnupg.org])
 #   (Interfaces removed:    CURRENT++, AGE=0, REVISION=0)
 #   (Interfaces added:      CURRENT++, AGE++, REVISION=0)
 #   (No interfaces changed:                   REVISION++)
-# CAUTION: Due to the ABI change in 1.6 the LT version numbers below have
-# already been set for the next release.  Thus don't update them for
-# the 1.6.0 release.
 LIBGCRYPT_LT_CURRENT=20
 LIBGCRYPT_LT_AGE=0
 LIBGCRYPT_LT_REVISION=0
 
 
 # If the API is changed in an incompatible way: increment the next counter.
+#
+# 1.6: ABI and API change but the change is to most users irrelevant
+#      and thus the API version number has not been incremented.
 LIBGCRYPT_CONFIG_API_VERSION=1
 
 # If you change the required gpg-error version, please remove