Prepare for new developments.
authorWerner Koch <wk@gnupg.org>
Thu, 22 Jan 2009 19:36:02 +0000 (19:36 +0000)
committerWerner Koch <wk@gnupg.org>
Thu, 22 Jan 2009 19:36:02 +0000 (19:36 +0000)
ChangeLog
NEWS
README
configure.ac

index bb87426..e8ea895 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,10 @@
 2009-01-22  Werner Koch  <wk@g10code.com>
 
+       * configure.ac: Bump LT version to C17/A7/R0 to mark the start of
+       a new development series.
+
+2009-01-22  Werner Koch  <wk@g10code.com>
+
        Release 1.4.4.
        
        * configure.ac: Bump LT version to C16/A5/R2.
diff --git a/NEWS b/NEWS
index e4a202b..a981224 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,3 +1,7 @@
+Noteworthy changes in version 1.5.x (unreleased)
+------------------------------------------------
+
+
 Noteworthy changes in version 1.4.4 (2009-01-22)
 ------------------------------------------------
 
diff --git a/README b/README
index 78dbd03..289296f 100644 (file)
--- a/README
+++ b/README
@@ -1,7 +1,9 @@
                    Libgcrypt - The GNU Crypto Library
                   ------------------------------------
-                            Version 1.4.4
+                            Version 1.5.x
  
+      WARNING: THIS VERSION OF LIBGCRYPT IS UNDER DEVELOPMENT.
+               THE STABLE VERSION IS THE 1.4.
 
     Copyright 2000, 2002, 2003, 2004, 2007, 2008,
               2009 Free Software Foundation, Inc.
index 50fb071..756cf11 100644 (file)
@@ -26,8 +26,8 @@ min_automake_version="1.10"
 # Remember to change the version number immediately *after* a release.
 # Set my_issvn to "yes" for non-released code.  Remember to run an
 # "svn up" and "autogen.sh" right before creating a distribution.
-m4_define([my_version], [1.4.4])
-m4_define([my_issvn], [no])
+m4_define([my_version], [1.5.0])
+m4_define([my_issvn], [yes])
 
 m4_define([svn_revision], m4_esyscmd([printf "%d" $(svn info 2>/dev/null \
           | sed -n '/^Revision:/ s/[^0-9]//gp'|head -1)]))
@@ -38,9 +38,10 @@ AC_INIT([libgcrypt],
 #   (Interfaces removed:    CURRENT++, AGE=0, REVISION=0)
 #   (Interfaces added:      CURRENT++, AGE++, REVISION=0)
 #   (No interfaces changed:                   REVISION++)
-LIBGCRYPT_LT_CURRENT=16
-LIBGCRYPT_LT_AGE=5
-LIBGCRYPT_LT_REVISION=2
+# NOTE: As an exception the the LT versions are already set for 1.5.0!
+LIBGCRYPT_LT_CURRENT=17
+LIBGCRYPT_LT_AGE=6
+LIBGCRYPT_LT_REVISION=0
 
 
 # If the API is changed in an incompatible way: increment the next counter.