Check that GNUTLS 3.0 has been installed.
authorWerner Koch <wk@gnupg.org>
Thu, 22 May 2014 14:02:22 +0000 (16:02 +0200)
committerWerner Koch <wk@gnupg.org>
Thu, 22 May 2014 14:02:22 +0000 (16:02 +0200)
* configure.ac (NEED_GNUTLS_VERSION): New.
(LIBGNUTLS): Fix gnutls version check.

README
configure.ac

diff --git a/README b/README
index 61a3b80..0e9e1f0 100644 (file)
--- a/README
+++ b/README
@@ -9,7 +9,7 @@ To run the daemon:
 
 Payprocd creates the socket /var/run/payproc/daemon and expect the CA
 root certificate in /etc/payproc/tls-ca.pem .  The given journal file
-name will be suffixed with the current data and ".log".  The time
+name will be suffixed with the current date and ".log".  The time
 stamp in the journal is given in UTC.
 
 
index b0a9b76..ed79c6d 100644 (file)
@@ -50,6 +50,8 @@ NEED_LIBASSUAN_VERSION=2.1.0
 NEED_NPTH_API=1
 NEED_NPTH_VERSION=0.91
 
+NEED_GNUTLS_VERSION=3.0
+
 development_version=mym4_isgit
 
 AC_CONFIG_AUX_DIR(build-aux)
@@ -144,7 +146,9 @@ AC_DEFINE(USE_NPTH, 1, [Defined to use New Portable Thread Library])
 #
 # GNUTLS
 #
-PKG_CHECK_MODULES([LIBGNUTLS], [gnutls >= 1.12])
+PKG_CHECK_MODULES([LIBGNUTLS], [gnutls >= $NEED_GNUTLS_VERSION],
+                               [have_gnutls=yes],
+                               [have_gnutls=no])
 AC_SUBST([LIBGNUTLS_CFLAGS])
 AC_SUBST([LIBGNUTLS_LIBS])
 AC_DEFINE(HTTP_USE_GNUTLS, 1, [Enable GNUTLS support in http.c])