Remove support form QT3 and GTK+-1.
authorWerner Koch <wk@gnupg.org>
Fri, 24 Oct 2014 14:20:20 +0000 (16:20 +0200)
committerWerner Koch <wk@gnupg.org>
Sun, 26 Oct 2014 10:26:09 +0000 (11:26 +0100)
* configure.ac: Remove old qt and gtk+-1 support.
* Makefile.am: Ditto.

Makefile.am
NEWS
README
configure.ac

index abc7b73..61c98e1 100644 (file)
@@ -41,24 +41,12 @@ else
 pinentry_tty =
 endif
 
-if BUILD_PINENTRY_GTK
-pinentry_gtk = gtk
-else
-pinentry_gtk =
-endif
-
 if BUILD_PINENTRY_GTK_2
 pinentry_gtk_2 = gtk+-2
 else
 pinentry_gtk_2 =
 endif
 
-if BUILD_PINENTRY_QT
-pinentry_qt = qt
-else
-pinentry_qt =
-endif
-
 if BUILD_PINENTRY_QT4
 pinentry_qt4 = qt4
 else
@@ -72,8 +60,7 @@ pinentry_w32 =
 endif
 
 SUBDIRS = assuan secmem pinentry ${pinentry_curses} ${pinentry_tty} \
-       ${pinentry_gtk} ${pinentry_gtk_2} ${pinentry_qt} ${pinentry_qt4} \
-       ${pinentry_w32} doc
+         ${pinentry_gtk_2} ${pinentry_qt4} ${pinentry_w32} doc
 
 
 install-exec-local:
diff --git a/NEWS b/NEWS
index 6a63d58..393af88 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,14 @@
-Noteworthy changes in version 0.8.5 (unreleased)
+Noteworthy changes in version 0.9.0 (unreleased)
 ------------------------------------------------
 
+ * New command SETREPEAT.  Currently only supported for Gtk+-2.
+
+ * Gtk+-2: Pasting using the mouse is now supported.
+
+ * curses: Check that it is actually connected to a tty.
+
+ * Removed the old qt-3 and gtk+-1 pinentries.
+
 
 Noteworthy changes in version 0.8.4 (2014-09-18)
 ------------------------------------------------
diff --git a/README b/README
index 6bb0d85..47d0a04 100644 (file)
--- a/README
+++ b/README
@@ -11,11 +11,8 @@ be requested explicitely.
 
 GUI            OPTION                   DEPENDENCIES
 Curses         --enable-pinentry-curses Curses library, for example ncurses
-GTK+ V1.2      --enable-pinentry-gtk    Gimp Toolkit Library Version 1.2
-                                        eg. libgtk-1.2 and libglib-1.2
 GTK+ V2.0      --enable-pinentry-gtk2   Gimp Toolkit Library, Version 2.0
                                         eg. libgtk-x11-2.0 and libglib-2.0
-Qt             --enable-pinentry-qt     Qt, eg. libqt or libqt-mt
 Qt4            --enable-pinentry-qt4    Qt4
 TTY            --enable-pinentry-tty    Simple TTY version, no dependencies
 
@@ -27,13 +24,13 @@ specified.  So to disable linking to curses completely you have to
 pass --disable-fallback-curses to the configure script as well.
 
 Examples:
-* To only build the GTK+ 1.2 pinentry with curses support:
-./configure --enable-pinentry-gtk --enable-fallback-curses \
-       --disable-pinentry-curses --disable-pinentry-qt
+* To only build the GTK+ pinentry with curses support:
+./configure --enable-pinentry-gtk2 --enable-fallback-curses \
+       --disable-pinentry-curses --disable-pinentry-qt4
 
 * To build the Qt pinentry, and the other pinentries if they are
   supported:
-./configure --enable-pinentry-qt
+./configure --enable-pinentry-qt4
 
 * To build everything that is supported (complete auto-detection):
 ./configure
index 0b00217..b930b84 100644 (file)
@@ -251,55 +251,10 @@ fi
 
 
 dnl
-dnl Check for GTK+ pinentry program.
+dnl Additional checks pinentry Curses.
 dnl
-AC_ARG_ENABLE(pinentry-gtk,
-            AC_HELP_STRING([--enable-pinentry-gtk], [build GTK+ pinentry]),
-            pinentry_gtk=$enableval, pinentry_gtk=maybe)
-
-dnl
-dnl Checks for GTK+ libraries.  Deal correctly with $pinentry_gtk = maybe.
-dnl
-if test "$pinentry_gtk" != "no"; then
-AM_PATH_GLIB(1.2.0,,
-if test "$pinentry_gtk" = "yes"; then
-    AC_MSG_ERROR([[
-***
-*** GLIB 1.2.0 or newer is required. The latest version of GLIB
-*** is always available from ftp://ftp.gtk.org/.
-***]])
-else
-    pinentry_gtk=no
-fi)
-fi
-
-if test "$pinentry_gtk" != "no"; then
-AM_PATH_GTK(1.2.0,
-    AC_DEFINE(HAVE_GTK, 1, [Defined if GTK is available]),
-if test "$pinentry_gtk" = "yes"; then
-    AC_MSG_ERROR([[
-***
-*** GTK+ 1.2.0 or newer is required. The latest version of GTK+
-*** is always available form ftp://ftp.gtk.org/.
-***]])
-else
-    pinentry_gtk=no
-fi)
-fi
-
-dnl If we have come so far, GTK+ pinentry can be build.
-if test "$pinentry_gtk" != "no"; then
-    pinentry_gtk=yes
-fi
-AM_CONDITIONAL(BUILD_PINENTRY_GTK, test "$pinentry_gtk" = "yes")
-if test "$pinentry_gtk" = "yes"; then
-  AC_DEFINE(PINENTRY_GTK, 1, [The GTK+ version of Pinentry is to be build])
-fi
-
 if test "$pinentry_curses" = "yes" \
-        -o "$fallback_curses" = "yes" \
-        -o "$pinentry_gtk" = "yes"; then
-  dnl Additional checks pinentry Curses/GTK+.
+        -o "$fallback_curses" = "yes" ; then
   AM_ICONV
   if test "$am_cv_func_iconv" != "yes"; then
     AC_MSG_ERROR([[
@@ -310,10 +265,6 @@ if test "$pinentry_curses" = "yes" \
   fi
 fi
 
-dnl if test "$pinentry_gtk" = "yes"; then
-dnl Additional checks for GTK+ pinentry.
-dnl End of additional checks for GTK+ pinentry.
-dnl fi
 
 
 dnl
@@ -361,64 +312,6 @@ AM_CONDITIONAL(BUILD_PINENTRY_GTK_2, test "$pinentry_gtk_2" = "yes")
 
 
 dnl
-dnl Check for Qt pinentry program.
-dnl
-AC_ARG_ENABLE(pinentry-qt,
-            AC_HELP_STRING([--enable-pinentry-qt], [build Qt pinentry]),
-            pinentry_qt=$enableval, pinentry_qt=maybe)
-dnl
-dnl Checks for Qt libraries.  Deal correctly with $pinentry_qt = maybe.
-dnl
-if test "$pinentry_qt" != "no"; then
-QT_CHECK_COMPILERS
-QT_PATH
-if test $have_qt = "no"; then
-       if test $pinentry_qt = "yes"; then
-         AC_MSG_ERROR([[
-***
-*** Qt ($qt_minversion) $ac_qt_notfound not found. Please check your
-*** installation!  For more details about this problem, look at the
-*** end of config.log.$missing_qt_mt
-***]])
-       else
-         pinentry_qt="no"
-       fi
-fi
-if test $have_moc = "no"; then
-       if test $pinentry_qt = "yes"; then
-        AC_MSG_ERROR([[
-***
-*** No Qt meta object compiler (moc) found!
-*** Please check whether you installed Qt correctly.
-*** You need to have a running moc binary.
-*** configure tried to run $ac_cv_path_moc and the test didn't
-*** succeed. If configure shouldn't have tried this one, set
-*** the environment variable MOC to the right one before running
-*** configure.
-***]])
-       else
-         pinentry_qt="no"
-       fi
-fi
-fi
-
-dnl If we have come so far, Qt pinentry can probably be build.
-if test "$pinentry_qt" != "no"; then
-    pinentry_qt=yes
-fi
-AM_CONDITIONAL(BUILD_PINENTRY_QT, test "$pinentry_qt" = "yes")
-
-if test "$pinentry_qt" = "yes"; then
-  AC_DEFINE(PINENTRY_QT, 1, [The Qt version of Pinentry is to be build])
-fi
-
-dnl if test "$pinentry_qt" = "yes"; then
-dnl dnl Additional checks for Qt pinentry.
-dnl dnl End of checks for Qt pinentry.
-dnl fi
-
-
-dnl
 dnl Check for Qt4 pinentry program.
 dnl
 AC_ARG_ENABLE(pinentry-qt4,
@@ -495,29 +388,21 @@ AM_CONDITIONAL(BUILD_PINENTRY_W32, test "$pinentry_w32" = "yes")
 # pinentry really is better (more feature-complete and more secure).
 
 if test "$pinentry_gtk_2" = "yes"; then
-   PINENTRY_DEFAULT=pinentry-gtk-2
+  PINENTRY_DEFAULT=pinentry-gtk-2
 else
-  if test "$pinentry_gtk" = "yes"; then
-    PINENTRY_DEFAULT=pinentry-gtk
+  if test "$pinentry_qt4" = "yes"; then
+    PINENTRY_DEFAULT=pinentry-qt4
   else
-    if test "$pinentry_qt" = "yes"; then
-      PINENTRY_DEFAULT=pinentry-qt
+    if test "$pinentry_curses" = "yes"; then
+      PINENTRY_DEFAULT=pinentry-curses
     else
-      if test "$pinentry_qt4" = "yes"; then
-        PINENTRY_DEFAULT=pinentry-qt4
+      if test "$pinentry_tty" = "yes"; then
+        PINENTRY_DEFAULT=pinentry-tty
       else
-        if test "$pinentry_curses" = "yes"; then
-          PINENTRY_DEFAULT=pinentry-curses
+        if test "$pinentry_w32" = "yes"; then
+          PINENTRY_DEFAULT=pinentry-w32
         else
-          if test "$pinentry_tty" = "yes"; then
-            PINENTRY_DEFAULT=pinentry-tty
-          else
-            if test "$pinentry_w32" = "yes"; then
-              PINENTRY_DEFAULT=pinentry-w32
-            else
-              AC_MSG_ERROR([[No pinentry enabled.]])
-            fi
-          fi
+          AC_MSG_ERROR([[No pinentry enabled.]])
         fi
       fi
     fi
@@ -532,9 +417,7 @@ secmem/Makefile
 pinentry/Makefile
 curses/Makefile
 tty/Makefile
-gtk/Makefile
 gtk+-2/Makefile
-qt/Makefile
 qt4/Makefile
 w32/Makefile
 doc/Makefile
@@ -552,9 +435,7 @@ AC_MSG_NOTICE([
 
        Curses Pinentry ..: $pinentry_curses
        TTY Pinentry .....: $pinentry_tty
-       GTK+ Pinentry ....: $pinentry_gtk
        GTK+-2 Pinentry ..: $pinentry_gtk_2
-       Qt Pinentry ......: $pinentry_qt
        Qt4 Pinentry .....: $pinentry_qt4 $pinentry_qt4_clip_msg
        W32 Pinentry .....: $pinentry_w32