Update documentation files.
authorDamien Goutte-Gattat <dgouttegattat@incenp.org>
Wed, 5 Jul 2017 19:52:25 +0000 (21:52 +0200)
committerDamien Goutte-Gattat <dgouttegattat@incenp.org>
Wed, 5 Jul 2017 19:54:47 +0000 (21:54 +0200)
* AUTHORS: Update bug report submission URL.
* doc/website/contact.xhtml: Likewise.
* NEWS: Update for upcoming release.
* README: Replace libscute.so by scute.so. Indicate that GnuPG 2.1
is required for some features.
* doc/manual/scute.texi: Likewise.

Signed-off-by: Damien Goutte-Gattat <dgouttegattat@incenp.org>
AUTHORS
NEWS
README
doc/manual/scute.texi
doc/website/contact.xhtml

diff --git a/AUTHORS b/AUTHORS
index 39ab03a..1eba0f1 100644 (file)
--- a/AUTHORS
+++ b/AUTHORS
@@ -1,6 +1,6 @@
 Package: scute
 Maintainer: Marcus Brinkmann <marcus@g10code.com>
-Bug reports: bug-scute@g10code.com
+Bug reports: https://dev.gnupg.org/
 Security related bug reports: security@gnupg.org
 License: GPLv2+ with exception for Mozilla
 
diff --git a/NEWS b/NEWS
index dc84747..e6608bb 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,4 +1,16 @@
-Noteworthy changes in version 1.3.0 (2010-04-21)
+Noteworthy changes in version 1.5.0 (unreleased)
+------------------------------------------------
+
+ * Support for TLS 1.2 client authentication and S/MIME signing.
+
+ * Support for 4096 bit keys.
+
+ * Support for GnuPG 2.1.
+
+ * C_GenerateRandom is implemented.
+
+
+Noteworthy changes in version 1.4.0 (2010-04-21)
 ------------------------------------------------
 
  * Update to libassuan 2.0.0 interface.
diff --git a/README b/README
index 7064b29..4cd9a12 100644 (file)
--- a/README
+++ b/README
@@ -42,6 +42,9 @@ At runtime:
 * GnuPG 2.0, in particular: gpg-agent, scdaemon
 * Pinentry
 
+Note that client authentication with TLS 1.2 and S/MIME signing
+require GnuPG 2.1.
+
 
 Installation
 ============
@@ -52,7 +55,7 @@ instructions in the file INSTALL that accompanies this software.
 After installation, you can configure Mozilla to use Scute by
 visiting the preferences dialog in the "advanced" category, under
 "Security Devices".  There you can "load" the module from its
-installed path, e.g. "/usr/lib/libscute.so".
+installed path, e.g. "/usr/lib/scute.so".
 
 
 Client Authentication
@@ -161,7 +164,7 @@ ask when establishing the initial connection).
 
 To actually perform the client authentication, the client needs to set
 up the web browser for use with Scute.  The Scute PKCS #11 module,
-installed under /usr/lib/libscute.so by default, needs to be loaded as
+installed under /usr/lib/scute.so by default, needs to be loaded as
 a security device in Firefox under
 Preferences->Advanced->Security->Certificates->Security Devices->Load
 When the security device is loaded, card insertion should cause the
index 7199edf..392cc98 100644 (file)
@@ -262,7 +262,9 @@ configured:
 @table @asis
 @item GnuPG
 Scute uses the GnuPG 2.0 framework to access the OpenPGP card and for
-certificate management.  The minimum version required is 2.0.0.
+certificate management.  The minimum version required is 2.0.0 for
+client authentication with TLS 1.0 and 1.1.  Client authentication
+with TLS 1.2, email and document signing require GnuPG 2.1.0.
 
 @item Pinentry
 Pinentry is a dependency of GnuPG 2.0, so it also needs to be installed
index 2e070d7..7fbe731 100644 (file)
@@ -61,7 +61,7 @@
        <h2>Bug Reports</h2>
        <p>
          All bug reports should be submitted to our <a
-         href="http://bugs.g10code.com/">bug tracking system</a> or
+         href="https://dev.gnupg.org/">bug tracking system</a> or
          sent via e-mail to the <a
          href="http://lists.gnupg.org/mailman/listinfo/gnupg-devel">GnuPG
          development mailing list.</a> Sensitive information can also