About to release 1.9.7
[gnupg.git] / NEWS
diff --git a/NEWS b/NEWS
index f5d2a55..763b770 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,43 @@
-Noteworthy changes in version 1.9.5
+Noteworthy changes in version 1.9.7 (2004-04-06)
 ------------------------------------------------
 
+ * Instrumented the modules for gpgconf.
+
+ * Added support for DINSIG card applications.
+
+ * Include the smimeCapabilities attribute with signed messages.
+
+ * Now uses the gettext domain "gnupg2" to avoid conflicts with gnupg
+   versions < 1.9.
+
+
+Noteworthy changes in version 1.9.6 (2004-03-06)
+------------------------------------------------
+
+ * Code cleanups and bug fixes.
+
+
+Noteworthy changes in version 1.9.5 (2004-02-21)
+------------------------------------------------
+
+ * gpg-protect-tool gets now installed into libexec as it ought to be.
+   Cleaned up the build system to better comply with the coding
+   standards.
+
+ * [gpgsm] The --import command is now able to autodetect pkcs#12
+   files and import secret and private keys from this file format.
+   A new command --export-secret-key-p12 is provided to allow
+   exporting of secret keys in PKCS\#12 format.
+
+ * [gpgsm] The pinentry will now present a description of the key for
+   whom the passphrase is requested.
+
+ * [gpgsm] New option --with-validation to check the validity of key
+   while listing it.
+
+ * New option --debug-level={none,basic,advanced,expert,guru} to map
+   the debug flags to sensitive levels on a per program base.
+
 
 Noteworthy changes in version 1.9.4 (2004-01-30)
 ------------------------------------------------