* gpgkeys_hkp.c (curl_mrindex_writer): Print a warning if we see HTML
[gnupg.git] / README
diff --git a/README b/README
index 4d30cb2..c2ee47a 100644 (file)
--- a/README
+++ b/README
@@ -1,21 +1,66 @@
-                   GnuPG - The GNU Privacy Guard
-                  -------------------------------
-                           Version 1.1
+                   The GNU Privacy Guard 2
+                  =========================
+                       Version 1.9.x
 
-       WARNING:  This is the current development branch
-                 of GnuPG.  THIS SHOULD NOT BE USED IN
-                 A PRODUCTION ENVIRONMENT.  It will
-                 change quite often and may have serious
-                 problems.  Use the GnuPG from the stable
-                 Branch 1.0.x  for real work.  The next
-                 stable release will be 1.2
 
-This version has been released due to the included libgcrypt which is 
-used by GNUTLS and might be of use for other software too.
+GnuPG 1.9 is the future version of GnuPG; it is based on the gnupg-1.4
+code and the previous newpg package.  It will very soon lead to a
+GnuPG 2.0 release.
 
-GPG itself does not work and will not be installed.
+You should use this GnuPG version if you want to use the gpg-agent or
+gpgsm (the S/MIME variant of gpg).  Note that the gpg-agent is also
+helpful when using the standard gpg version (1.4.x).  There are no
+problems installing 1.4 and 1.9 alongside; in fact we suggest to do
+this.
 
 
+BUILD INSTRUCTIONS
+==================
 
+GnuPG 1.9 depends on the following packages:
 
+  libgpg-error (ftp://ftp.gnupg.org/gcrypt/libgpg-error/)
+  libgcrypt    (ftp://ftp.gnupg.org/gcrypt/libgcrypt/)
+  libksba      (ftp://ftp.gnupg.org/gcrypt/libksba/)
+  libassuan    (ftp://ftp.gnupg.org/gcrypt/alpha/libassuan/)
+  
+You also need the pinentry package for most function of GnuPG; however
+it is not a build requirement.  pinentry is available at
+ftp://ftp.gnupg.org/gcrypt/pinentry/ .
+
+You should get the latest versions of course, the GnuPG configure
+script complains if a version is not sufficient.
+
+After building and installing the above packages in the order as given
+above, you may now continue with GnuPG installation (you may also just
+try to build GnuPG to see whether your already installed versions are
+sufficient).
+
+As with all packages, you just have to do
+
+ ./configure
+ make
+ make install
+
+(Before doing install you might need to become root.)
+
+If everything succeeds, you have a working GnuPG with support for
+S/MIME and smartcards.  Note that there is no binary gpg but a gpg2 so
+that this package won't conflict with a GnuPG 1.4 installation. gpg2
+behaves just like gpg.
+
+In case of problem please ask on gnupg-users@gnupg.org for advise.  Note
+that this release is only expected to build on GNU and *BSD systems.
+
+
+
+DOCUMENTATION
+==================
+
+The complete documentation is in the texinfo manual named
+`gnupg.info'.  Run "info gnupg" to read it.  If you want a a printable
+copy of the manual, change to the "doc" directory and enter "make
+gnupg.pdf".  For a HTML version enter "make gnupg.html" and point your
+browser to gnupg.html/index.html.  Standard man pages for all
+components are provided as well.