* configure.ac: Allow setting USE_EXEC_PATH to lock the exec-path to a
[gnupg.git] / configure.ac
index c816ab7..65bc087 100644 (file)
@@ -25,7 +25,7 @@ AC_PREREQ(2.52)
 # Please enter the version number here and set development_version to
 # yes if the minor number is odd or you feel that the default check 
 # for a development version is not sufficient.
-AC_INIT(gnupg, 1.1.90, bug-gnupg@gnu.org)
+AC_INIT(gnupg, 1.1.91, bug-gnupg@gnu.org)
 development_version=yes
 
 ALL_LINGUAS="cs da de eo el es et fr gl id it ja nl pl pt_BR pt sv tr"
@@ -130,6 +130,17 @@ if test "$use_exec" = no ; then
 fi
 
 if test "$use_exec" = yes ; then
+  AC_MSG_CHECKING([for a restricted exec-path])
+  AC_ARG_WITH(exec-path,
+      [  --with-exec-path=PATH        restrict exec-path to PATH],
+      [if test "$withval" = yes ; then
+         withval=no
+      else
+         AC_DEFINE_UNQUOTED(USE_EXEC_PATH,"$withval",
+                           [restrict exec-path to this])
+      fi],withval=no)
+  AC_MSG_RESULT($withval)
+
   AC_MSG_CHECKING([whether LDAP keyserver support is requested])
   AC_ARG_ENABLE(ldap,
   [  --disable-ldap          disable LDAP keyserver interface],
@@ -882,7 +893,7 @@ GNUPG_CHECK_GNUMAKE
 # mysterious reasons - the final link step should bail out. 
 case "${target}" in
     *-*-mingw32*)
-        LIBS="$LIBS -lws2_32"
+        LIBS="$LIBS -lwsock32"
         ;;
     *)
        ;;