Remove hacks which are not anymore needed since we now require Libgcrypt 1.4
[gnupg.git] / g10 / sign.c
index 022622b..597aba7 100644 (file)
@@ -346,9 +346,7 @@ match_dsa_hash (unsigned int qbytes)
   if (qbytes <= 20)
     return DIGEST_ALGO_SHA1;
 
-  /* SHA244 is only available with libgcrypt 1.4 - thus do a runtime
-     test.  */
-  if (qbytes <= 28 && !gcry_md_test_algo (DIGEST_ALGO_SHA224))
+  if (qbytes <= 28)
     return DIGEST_ALGO_SHA224;
 
   if (qbytes <= 32)