Remove hacks which are not anymore needed since we now require Libgcrypt 1.4
[gnupg.git] / sm / certcheck.c
index 7f26f80..51a809b 100644 (file)
 #include "i18n.h"
 
 
-/* Remove this if libgcrypt 1.3.0 is required. */
-#define MY_GCRY_PK_ECDSA  301
-
-
 /* Return the number of bits of the Q parameter from the DSA key
    KEY.  */
 static unsigned int
@@ -75,11 +71,11 @@ do_encode_md (gcry_md_hd_t md, int algo, int pkalgo, unsigned int nbits,
   size_t nframe;
   unsigned char *frame;
 
-  if (pkalgo == GCRY_PK_DSA || pkalgo == MY_GCRY_PK_ECDSA)
+  if (pkalgo == GCRY_PK_DSA || pkalgo == GCRY_PK_ECDSA)
     {
       unsigned int qbits;
 
-      if ( pkalgo == MY_GCRY_PK_ECDSA )
+      if ( pkalgo == GCRY_PK_ECDSA )
         qbits = gcry_pk_get_nbits (pkey);
       else
         qbits = get_dsa_qbits (pkey);
@@ -214,7 +210,7 @@ pk_algo_from_sexp (gcry_sexp_t pkey)
   /* Because this function is called only for verification we can
      assume that ECC actually means ECDSA.  */
   else if (n==3 && !memcmp (name, "ecc", 3))
-    algo = MY_GCRY_PK_ECDSA;
+    algo = GCRY_PK_ECDSA;
   else if (n==13 && !memcmp (name, "ambiguous-rsa", 13))
     algo = GCRY_PK_RSA;
   else