Add more passphrase policy rules.
[gnupg.git] / tools / Makefile.am
index 4fda65d..a9004a7 100644 (file)
@@ -46,9 +46,13 @@ if !HAVE_W32_SYSTEM
 bin_PROGRAMS += watchgnupg gpgparsemail
 endif
 
+if !DISABLE_REGEX
+libexec_PROGRAMS = gpg-check-pattern
+endif
+
 noinst_PROGRAMS = clean-sat mk-tdata make-dns-cert gpgsplit
 
-common_libs = ../jnlib/libjnlib.a $(libcommon) ../gl/libgnu.a
+common_libs = $(libcommon) ../jnlib/libjnlib.a ../gl/libgnu.a
 pwquery_libs = ../common/libsimple-pwquery.a
 
 gpgsplit_LDADD = $(common_libs) \
@@ -86,6 +90,13 @@ gpgkey2ssh_LDADD = $(common_libs) \
                    $(LIBGCRYPT_LIBS) $(GPG_ERROR_LIBS) $(LIBINTL) $(LIBICONV)
 
 
+if !DISABLE_REGEX
+gpg_check_pattern_SOURCES = gpg-check-pattern.c
+gpg_check_pattern_CFLAGS = $(LIBGCRYPT_CFLAGS) $(GPG_ERROR_CFLAGS)
+gpg_check_pattern_LDADD = $(common_libs) $(LIBGCRYPT_LIBS) $(GPG_ERROR_LIBS) \
+                          $(LIBINTL) $(LIBICONV) $(W32SOCKLIBS)
+endif
+
 # Make sure that all libs are build before we use them.  This is
 # important for things like make -j2.
 $(PROGRAMS): $(common_libs) $(pwquery_libs)