gpg: Remove options --pgp2 and --rfc1991.
authorWerner Koch <wk@gnupg.org>
Tue, 12 Aug 2014 08:36:30 +0000 (10:36 +0200)
committerWerner Koch <wk@gnupg.org>
Thu, 14 Aug 2014 09:03:55 +0000 (11:03 +0200)
commit2b8d8369d59249b89526c18c5ac276e6445dc35e
treecee8f7b5adb668e0893ab13812c571db329b119b
parent49c9a958e0b786850309bca555d4465c97d337e1
gpg: Remove options --pgp2 and --rfc1991.

* g10/gpg.c (oRFC1991, oPGP2): Remove
(opts): Remove --pgp2 and --rfc1991.
* g10/options.h (CO_PGP2, CO_RFC1991): Remove.  Remove all users.
(RFC2440, PGP2): Remove.  Remove all code only enabled by these
conditions.
* tests/openpgp/clearsig.test: Remove --rfc1991 test.
--

The use of PGP 2.c is considered insecure for quite some time
now (e.g. due to the use of MD5).  Thus we remove all support for
_creating_ PGP 2 compatible messages.
14 files changed:
NEWS
doc/gpg.texi
g10/cipher.c
g10/encrypt.c
g10/gpg.c
g10/keyedit.c
g10/keygen.c
g10/misc.c
g10/options.h
g10/pkclist.c
g10/revoke.c
g10/server.c
g10/sign.c
tests/openpgp/clearsig.test