Require libgpg-error 1.11.
authorWerner Koch <wk@gnupg.org>
Mon, 19 Aug 2013 11:08:37 +0000 (13:08 +0200)
committerWerner Koch <wk@gnupg.org>
Mon, 19 Aug 2013 11:08:37 +0000 (13:08 +0200)
commit2d360a96375843c437680b28a4f96f176d70a7c1
tree2515d71e82d0cba64655564e2227659b001183ce
parent284e387707ef14f8f999f7b5cc869cfa74e51f17
Require libgpg-error 1.11.

* configure.ac (NEED_GPG_ERROR_VERSION): Set to 1.11.
* common/util.h: Remove GPG_ERR_ replacements.
--

The replacement macros actually never worked because gog-error.h uses
enums and not macros.  libgpg-error 1.11 is 6 months old and thus it
should not be a problem to require that version.

Future replacement macros may then use the new
GPG_ERROR_VERSION_NUMBER to detect missing error codes.

Signed-off-by: Werner Koch <wk@gnupg.org>
common/util.h
configure.ac