* configure.ac: Do not build gpg by default.
authorWerner Koch <wk@gnupg.org>
Thu, 21 Apr 2005 09:33:07 +0000 (09:33 +0000)
committerWerner Koch <wk@gnupg.org>
Thu, 21 Apr 2005 09:33:07 +0000 (09:33 +0000)
commit3ff9a743bf6faeb99e8ee6113fe54af4f34cc288
tree25233f57f101ec9c2a8272575a02087aa08abb8f
parent314c234e7d1320bcd13e5130c3d7074b19979e46
* configure.ac: Do not build gpg by default.

* gpgsm.c: New options --{enable,disable}-trusted-cert-crl-check.
* certchain.c (gpgsm_validate_chain): Make use of it.

* certchain.c (gpgsm_validate_chain): Check revocations even for
expired certificates.  This is required because on signature
verification an expired key is fine whereas a revoked one is not.

* gpgconf-comp.c: Add gpgsm option disable-trusted-cert-crl-check.
15 files changed:
ChangeLog
README
TODO
configure.ac
doc/gpgsm.texi
scd/ChangeLog
scd/ccid-driver.c
scd/command.c
sm/ChangeLog
sm/certchain.c
sm/gpgsm.c
sm/gpgsm.h
tools/ChangeLog
tools/gpgconf-comp.c
tools/symcryptrun.c