gpg: Obsolete some keyserver helper options.
authorWerner Koch <wk@gnupg.org>
Mon, 8 Dec 2014 14:14:35 +0000 (15:14 +0100)
committerWerner Koch <wk@gnupg.org>
Mon, 8 Dec 2014 14:14:35 +0000 (15:14 +0100)
commit5bf93f4ea7a11381dd256b5fd4e5913366828265
tree45a588f8f2d1fbc4daa4e07eddcee5a1575f46dc
parentcdc404fe5247fb9886a7aeb9f214a04fc88b7aa0
gpg: Obsolete some keyserver helper options.

* g10/options.h (opt): Remove keyserver_options.other.
* g10/gpg.c (main): Obsolete option --honor-http-proxt.
* g10/keyserver.c (add_canonical_option): Replace by ...
(warn_kshelper_option): New.
(parse_keyserver_uri): Obsolete "x-broken-http".
--

Some of these options are deprecated for 10 years and they do not make
any sense without the keyserver helpers.  For one we print a hint on
how to replace it:

  gpg: keyserver option 'ca-cert-file' is obsolete; \
  please use 'hkp-cacert' in dirmngr.conf

Signed-off-by: Werner Koch <wk@gnupg.org>
g10/gpg.c
g10/keyserver.c
g10/options.h