* configure.ac: Require libksba 0.9.7.
authorWerner Koch <wk@gnupg.org>
Sun, 6 Jun 2004 13:00:59 +0000 (13:00 +0000)
committerWerner Koch <wk@gnupg.org>
Sun, 6 Jun 2004 13:00:59 +0000 (13:00 +0000)
commitf289f433b6d7f0b5ac76e03853ce628f23e3cdc2
tree4170844bd2e7c143fab1bf498d9136a0fe021a1f
parent438ece068bdedcdd20e5bfb4bddfa94e216735d2
* configure.ac: Require libksba 0.9.7.

* certreqgen.c (get_parameter_uint, create_request): Create
an extension for key usage when requested.

* gpgsm.c (main): Install emergency_cleanup also as an atexit
handler.

* verify.c (gpgsm_verify): Removed the separate error code
handling for KSBA.  We use shared error codes anyway.

* export.c (export_p12): Removed debugging code.

* encrypt.c (gpgsm_encrypt): Put the session key in to secure memory.
13 files changed:
ChangeLog
NEWS
TODO
configure.ac
sm/ChangeLog
sm/certreqgen.c
sm/decrypt.c
sm/encrypt.c
sm/export.c
sm/gpgsm.c
sm/keydb.c
sm/sign.c
sm/verify.c