Remove dependency to simple-pwquery.
authorWerner Koch <wk@gnupg.org>
Wed, 14 Apr 2010 16:52:02 +0000 (16:52 +0000)
committerWerner Koch <wk@gnupg.org>
Wed, 14 Apr 2010 16:52:02 +0000 (16:52 +0000)
agent/ChangeLog
agent/Makefile.am

index 264ad53..46e0b6f 100644 (file)
@@ -2,6 +2,7 @@
 
        * Makefile.am (libexec_PROGRAMS) [W32CE]: Do not build
        gpg-preset-passphrase for now.
+       (pwquery_libs) [W32CE]: Set to empty.
 
        * trustlist.c (read_one_trustfile): Use estream.
 
index 8ec8193..9258fc8 100644 (file)
@@ -51,7 +51,11 @@ gpg_agent_SOURCES = \
 
 common_libs = $(libcommon) ../gl/libgnu.a
 commonpth_libs = $(libcommonpth) ../gl/libgnu.a
+if HAVE_W32CE_SYSTEM
+pwquery_libs = 
+else
 pwquery_libs = ../common/libsimple-pwquery.a
+endif
 
 #if HAVE_W32_SYSTEM
 #.rc.o: