Silence deprecated warnings from gcc 4.6.3.
authorWerner Koch <wk@gnupg.org>
Wed, 3 Jul 2013 10:59:56 +0000 (12:59 +0200)
committerWerner Koch <wk@gnupg.org>
Wed, 3 Jul 2013 10:59:56 +0000 (12:59 +0200)
* configure.ac (AH_BOTTOM): Define GCRYPT_NO_DEPRECATED.
--

Frankly, I don't understand why gcc prints them.  We don't use them.

Signed-off-by: Werner Koch <wk@gnupg.org>
configure.ac

index b85124c..702b8d3 100644 (file)
@@ -442,6 +442,9 @@ AH_BOTTOM([
 /* We don't want the old assuan codes anymore. */
 #define _ASSUAN_ONLY_GPG_ERRORS 1
 
+/* We don't need any of the old gcrypt functions.  */
+#define GCRYPT_NO_DEPRECATED 1
+
 /* We explicitly need to disable PTH's soft mapping as Debian
    currently enables it by default for no reason. */
 #define PTH_SYSCALL_SOFT 0