gpgscm: Fix gcrypt version check.
authorWerner Koch <wk@gnupg.org>
Mon, 19 Sep 2016 06:41:51 +0000 (08:41 +0200)
committerWerner Koch <wk@gnupg.org>
Mon, 19 Sep 2016 06:41:51 +0000 (08:41 +0200)
* tests/gpgscm/main.c (main): Check against required and not installed
version.

Signed-off-by: Werner Koch <wk@gnupg.org>
tests/gpgscm/main.c

index 9aef1f3..02681ff 100644 (file)
@@ -230,7 +230,7 @@ main (int argc, char **argv)
   i18n_init ();
   init_common_subsystems (&argc, &argv);
 
-  if (!gcry_check_version (GCRYPT_VERSION))
+  if (!gcry_check_version (NEED_LIBGCRYPT_VERSION))
     {
       fputs ("libgcrypt version mismatch\n", stderr);
       exit (2);