Fix problem with incompatible gpg.conf files.
authorWerner Koch <wk@gnupg.org>
Sun, 19 Apr 2009 16:34:21 +0000 (16:34 +0000)
committerWerner Koch <wk@gnupg.org>
Sun, 19 Apr 2009 16:34:21 +0000 (16:34 +0000)
tests/openpgp/ChangeLog
tests/openpgp/mkdemodirs

index 118e03a..078c286 100644 (file)
@@ -1,3 +1,7 @@
+2009-04-19  Werner Koch  <wk@g10code.com>
+
+       * mkdemodirs (GPG): Use --no-options.
+
 2008-09-29  Werner Koch  <wk@g10code.com>
 
        * clearsig.test: Replace -sat by --clearsign.
index 2179080..7e6ec2c 100755 (executable)
@@ -2,7 +2,11 @@
 
 set -e
 
-GPG="../g10/gpg2 --batch --quiet --no-secmem-warning --allow-secret-key-import"
+# We need to use --no-options so that a gpg.conf from an older version
+# of gpg is not used.
+GPG="../g10/gpg2 --no-options --batch --quiet
+     --no-secmem-warning --allow-secret-key-import"
+
 NAMES='Alpha Bravo Charlie Delta Echo Foxtrot Golf Hotel India
        Juliet Kilo Lima Mike November Oscar Papa Quebec Romeo
        Sierra Tango Uniform Victor Whisky XRay Yankee Zulu'