common: Add substitute code for libgpg-error < 1.22.
authorWerner Koch <wk@gnupg.org>
Tue, 19 Jan 2016 15:26:28 +0000 (16:26 +0100)
committerWerner Koch <wk@gnupg.org>
Tue, 19 Jan 2016 15:26:28 +0000 (16:26 +0100)
* common/util.h (GPG_ERR_DB_CORRUPTED): New.

common/util.h

index 5d94e93..6410b11 100644 (file)
 
 /* These error codes are used but not defined in the required
    libgpg-error version.  Define them here. */
-/* None right now.  (Use #if GPG_ERROR_VERSION_NUMBER < 0x011500  / * 1.21) */
-
+/* Example: (#if GPG_ERROR_VERSION_NUMBER < 0x011500 // 1.21) */
+#if GPG_ERROR_VERSION_NUMBER < 0x011600  /* 1.22 */
+# define GPG_ERR_DB_CORRUPTED  218
+#endif /* gpg_error < 1.22 */
 
 /* Hash function used with libksba. */
 #define HASH_FNC ((void (*)(void *, const void*,size_t))gcry_md_write)