Release 2.2.3 gnupg-2.2.3
authorWerner Koch <wk@gnupg.org>
Mon, 20 Nov 2017 11:39:16 +0000 (12:39 +0100)
committerWerner Koch <wk@gnupg.org>
Mon, 20 Nov 2017 11:39:16 +0000 (12:39 +0100)
NEWS
README

diff --git a/NEWS b/NEWS
index ce6c5d7..38a8da1 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,21 @@
-Noteworthy changes in version 2.2.3 (unreleased)
+Noteworthy changes in version 2.2.3 (2017-11-20)
 ------------------------------------------------
 
+  * gpgsm: Fix initial keybox creation on Windows. [#3507]
+
+  * dirmngr: Fix crash in case of a CRL loading error. [#3510]
+
+  * Fix the name of the Windows registry key. [Git#4f5afaf1fd]
+
+  * gpgtar: Fix wrong behaviour of --set-filename. [#3500]
+
+  * gpg: Silence AKL retrieval messages. [#3504]
+
+  * agent: Use clock or clock_gettime for calibration. [#3056]
+
+  * agent: Improve robustness of the shutdown pending
+    state. [Git#7ffedfab89]
+
 
 Noteworthy changes in version 2.2.2 (2017-11-07)
 ------------------------------------------------
@@ -44,6 +59,8 @@ Noteworthy changes in version 2.2.2 (2017-11-07)
 
   * Add configure option --enable-werror.  [#2423]
 
+  See-also: gnupg-announce/2017q4/000416.html
+
 
 Noteworthy changes in version 2.2.1 (2017-09-19)
 ------------------------------------------------
diff --git a/README b/README
index dd66dab..23f705a 100644 (file)
--- a/README
+++ b/README
 
   GnuPG 2.2 depends on the following GnuPG related packages:
 
-    npth         (ftp://ftp.gnupg.org/gcrypt/npth/)
-    libgpg-error (ftp://ftp.gnupg.org/gcrypt/libgpg-error/)
-    libgcrypt    (ftp://ftp.gnupg.org/gcrypt/libgcrypt/)
-    libksba      (ftp://ftp.gnupg.org/gcrypt/libksba/)
-    libassuan    (ftp://ftp.gnupg.org/gcrypt/libassuan/)
+    npth         (https://gnupg.org/ftp/gcrypt/npth/)
+    libgpg-error (https://gnupg.org/ftp/gcrypt/libgpg-error/)
+    libgcrypt    (https://gnupg.org/ftp/gcrypt/libgcrypt/)
+    libksba      (https://gnupg.org/ftp/gcrypt/libksba/)
+    libassuan    (https://gnupg.org/ftp/gcrypt/libassuan/)
 
   You should get the latest versions of course, the GnuPG configure
   script complains if a version is not sufficient.
@@ -48,7 +48,7 @@
 
   You also need the Pinentry package for most functions of GnuPG;
   however it is not a build requirement.  Pinentry is available at
-  ftp://ftp.gnupg.org/gcrypt/pinentry/ .
+  https://gnupg.org/ftp/gcrypt/pinentry/ .
 
   After building and installing the above packages in the order as
   given above, you may continue with GnuPG installation (you may also
   You subscribe to one of the list by sending mail with a subject of
   "subscribe" to x-request@gnupg.org, where x is the name of the
   mailing list (gnupg-announce, gnupg-users, etc.). See
-  https://www.gnupg.org/documentation/mailing-lists.html for archives
+  https://gnupg.org/documentation/mailing-lists.html for archives
   of the mailing lists.
 
   Please direct bug reports to [[https://bugs.gnupg.org]] or post them
   authors and we try to answer questions when time allows us.
 
   Commercial grade support for GnuPG is available; for a listing of
-  offers see https://www.gnupg.org/service.html .  Maintaining and
+  offers see https://gnupg.org/service.html .  Maintaining and
   improving GnuPG requires a lot of time.  Since 2001, g10 Code GmbH,
   a German company owned and headed by GnuPG's principal author Werner
   Koch, is bearing the majority of these costs.  To keep GnuPG in a