* README-alpha: Removed. V1-9-3
authorWerner Koch <wk@gnupg.org>
Tue, 23 Dec 2003 11:05:19 +0000 (11:05 +0000)
committerWerner Koch <wk@gnupg.org>
Tue, 23 Dec 2003 11:05:19 +0000 (11:05 +0000)
* configure.ac, Makefile.am: Add the tests and tools directories.

ChangeLog
Makefile.am
NEWS
README
README-alpha [deleted file]
configure.ac

index 2d3eb56..0752eec 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,9 @@
 2003-12-23  Werner Koch  <wk@gnupg.org>
 
-       * configure.ac, Makefile.am: Enable the tests directory.
+       Released 1.9.3.
+
+       * README-alpha: Removed.
+       * configure.ac, Makefile.am: Add the tests and tools directories.
 
 2003-12-19  Werner Koch  <wk@gnupg.org>
 
@@ -11,7 +14,6 @@
 
        * configure.ac: Requires now libassuan 0.6.2.
        (CFLAGS): Add --Wformat-noliteral in gcc mode.
-       
 
 2003-12-16  Werner Koch  <wk@gnupg.org>
 
index 732d9e4..8f7d177 100644 (file)
@@ -21,7 +21,7 @@
 
 ACLOCAL_AMFLAGS = -I m4
 
-EXTRA_DIST = scripts/config.rpath  autogen.sh README-alpha README.CVS
+EXTRA_DIST = scripts/config.rpath autogen.sh README.CVS
 DISTCLEANFILES = g10defs.h 
 
 if BUILD_GPG
@@ -46,7 +46,7 @@ scd =
 endif
 
 SUBDIRS = m4 intl jnlib common kbx \
- ${gpg} ${sm} ${agent} ${scd} po doc tests
+ ${gpg} ${sm} ${agent} ${scd} tools po doc tests
 
 dist-hook:
        @set -e; \
diff --git a/NEWS b/NEWS
index ea7960c..efa85b1 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,4 +1,4 @@
-Noteworthy changes in version 1.9.3 (unreleased)
+Noteworthy changes in version 1.9.3 (2003-12-23)
 ------------------------------------------------
 
  * New gpgsm options --{enable,disable}-ocsp to validate keys using
diff --git a/README b/README
index 60b6133..42099d6 100644 (file)
--- a/README
+++ b/README
@@ -1,12 +1,15 @@
-GnuPG 1.9 is a temporary protect to work on GnuPG extensions.  It will
-eventually lead to a GnuPG 2.0 release.
+GnuPG 1.9 is a temporary project to work on GnuPG extensions; it is a
+merke fo gnupg 1.3 and the old newpg package.  It will eventually lead
+to a GnuPG 2.0 release.
 
 jnlib/  utility functions
 kbx/    keybox library
+g10/    the gpg program here called gpg2
 sm/     the gpgsm program
 agent/  the gpg-agent
 scd/    the smartcard daemon
 
+
 You need the libgpg-error package.  Libassuan, Libksba and Libgcrypt
 are also required to build it.
 
@@ -24,14 +27,14 @@ gpgsm:
 
 --learn-card
 
-   Read tinformation about the private keys from the smartcard and
+   Read information about the private keys from the smartcard and
    import the certificates from there.
 
 --export
 
-    Export all certificates storein the Keybox or those specified on
-    the commandline.  When using --armor a few informational lines are
-    prepended before each block.
+   Export all certificates stored in the Keybox or those specified on
+   the command line.  When using --armor a few informational lines are
+   prepended before each block.
 
 
 gpg2:
@@ -94,7 +97,7 @@ gpgsm:
 
   Specify a dirmngr program to be used for CRL checks.  The default
   value is "/usr/sbin/dirmngr".  This is only used as a fallback when
-  the envrionment varaibale DIRMNGR_INFO is not set or a running
+  the environment varaibale DIRMNGR_INFO is not set or a running
   dirmngr can't be connected.
 
 --no-secmem-warning
@@ -148,12 +151,11 @@ gpg-agent:
 --pinentry-program <path_to_pinentry_program>
 
   Specify the PINentry program.  The default value is
-  "../../pinentry/kpinentry/kpinentry" so you most likely want to
-  specify it. 
+  "<prefix>/bin/pinentry" so you most likely want to specify it.
 
 --no-grab
 
-  Tel the pinentry not to grab keybourd and mouse.  You most likely
+  Tell the pinentry not to grab keybourd and mouse.  You most likely
   want to give this option during testing and development to avoid
   lockups in case of bugs.
 
diff --git a/README-alpha b/README-alpha
deleted file mode 100644 (file)
index b844eab..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-       ====== THIS IS WORK IN PROGESS ======
-
-       DO NOT USE IN A PRODUCTION ENVIRONMENT!
-
-         THERE MIGHT BE SECURITY PROBLEMS!
-
-The source may change quite often and may have serious problems; it
-may even not compile on some machines.
-
-It will probably needs GCC and GLIBC to build due to some debugging
-code.  Please don't complain if it does not work on other machines.
-We will make it work again later.
-
-The specification for the OpenPGP smartcard application will be
-released soon and we will try to make cards easily available.
-
index fd0c995..1f3a6b0 100644 (file)
@@ -24,7 +24,7 @@ min_automake_version="1.7.6"
 
 # Version number: Remember to change it immediately *after* a release.
 #                 Add a "-cvs" prefix for non-released code.
-AC_INIT(gnupg, 1.9.3-cvs, gnupg-devel@gnupg.org)
+AC_INIT(gnupg, 1.9.3, gnupg-devel@gnupg.org)
 # Set development_version to yes if the minor number is odd or you
 # feel that the default check for a development version is not
 # sufficient.
@@ -1073,6 +1073,7 @@ g10/Makefile
 sm/Makefile
 agent/Makefile
 scd/Makefile
+tools/Makefile
 doc/Makefile
 tests/Makefile
 ])