Silence compiler warning about deprecated Libgcrypt symbols
authorWerner Koch <wk@gnupg.org>
Thu, 1 Aug 2013 09:06:22 +0000 (11:06 +0200)
committerWerner Koch <wk@gnupg.org>
Thu, 1 Aug 2013 09:06:22 +0000 (11:06 +0200)
* configure.ac (AH_BOTTOM): Define GCRYPT_NO_DEPRECATED.
--

Some gcc versions emit deprecated warning for such flagged Libgcrypt
symbols; even if they are not used.

configure.ac

index 01530e0..5a5e9f4 100644 (file)
@@ -500,6 +500,9 @@ AH_BOTTOM([
 /* Tell libgcrypt not to use its own libgpg-error implementation. */
 #define USE_LIBGPG_ERROR 1
 
+/* Tell Libgcrypt not to include deprecated definitions.  */
+#define GCRYPT_NO_DEPRECATED 1
+
 /* We use jnlib, so tell other modules about it.  */
 #define HAVE_JNLIB_LOGGING 1