From stable branch
authorDavid Shaw <dshaw@jabberwocky.com>
Wed, 18 Sep 2002 20:37:05 +0000 (20:37 +0000)
committerDavid Shaw <dshaw@jabberwocky.com>
Wed, 18 Sep 2002 20:37:05 +0000 (20:37 +0000)
2002-09-14  David Shaw  <dshaw@jabberwocky.com>

* configure.ac: Try linking LDAP without -lresolv first, just in
case the platform has libresolv, but doesn't actually need it to
use LDAP.

2002-09-12  David Shaw  <dshaw@jabberwocky.com>

* NEWS: Note that the old IDEA plugin won't work with post-1.1.90
gpg.

ChangeLog
NEWS
configure.ac

index c2d7540..000f166 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,14 @@
+2002-09-14  David Shaw  <dshaw@jabberwocky.com>
+
+       * configure.ac: Try linking LDAP without -lresolv first, just in
+       case the platform has libresolv, but doesn't actually need it to
+       use LDAP.
+
+2002-09-12  David Shaw  <dshaw@jabberwocky.com>
+
+       * NEWS: Note that the old IDEA plugin won't work with post-1.1.90
+       gpg.
+
 2002-09-12  David Shaw  <dshaw@jabberwocky.com>
 
        * configure.ac: Remove --enable-external-hkp as this is always on
diff --git a/NEWS b/NEWS
index d0f374e..f5c207a 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -60,6 +60,10 @@ Noteworthy changes in version 1.1.91 (2002-08-04)
       option is in general not useful anymore.  The only exception is
       to specify the deprecated idea cipher.
 
+    * The IDEA plugin has changed.  Previous versions of the IDEA
+      plugin will no longer work with GnuPG.  However, the current
+      version of the plugin will work with earlier GnuPG versions.
+
     * When using --batch with one of the --delete-key commands, the
       key must be specified by fingerprint.  See the man page for
       details.
index 506bae5..bdb7854 100644 (file)
@@ -359,7 +359,7 @@ AC_CHECK_FUNC(setsockopt, , AC_CHECK_LIB(socket, setsockopt,
 # is for Mozilla LDAP.
 
 if test "$try_ldap" = yes ; then
-  for LDAPLIBS in "-lldap -llber -lresolv" "-lldap -llber" "-lldapssl41"; do
+  for LDAPLIBS in "-lldap -llber" "-lldap -llber -lresolv" "-lldapssl41"; do
     _ldap_save_libs=$LIBS
     LIBS="$LDAPLIBS $NETLIBS $LIBS"