Remove hacks which are not anymore needed since we now require Libgcrypt 1.4