gpg: Fix the use of future-default with --quick-add-key.