build: Build gpg-pair-tool only when there is newer libgcrypt.