2004-09-30 Marcus Brinkmann <marcus@g10code.de>
[gpgme.git] / README
1                   GPGME - GnuPG Made Easy
2                 ---------------------------
3
4 To build GPGME, you need to install libgpg-error.  You need at least
5 libgpg-error 0.5.
6
7 For support of the OpenPGP protocol (default), you should use the
8 latest version of GnuPG 1.2, available at:
9 ftp://ftp.gnupg.org/gcrypt/gnupg/
10
11 You need at least GnuPG 1.2.2.
12
13 If configure can't find the `gpg' binary in your path, you can specify
14 the location with the --with-gpg=/path/to/gpg argument to configure.
15
16 For support of the CMS (Cryptographic Message Syntax) protocol, you
17 need the latest CVS version of GnuPG 1.9, which is available in the
18 GnuPG repository:
19 http://www.gnupg.org/(en)/download/cvs_access.html
20 Use the tag `GNUPG-1-9-BRANCH'.  There are also snapshots available at:
21 ftp://ftp.gnupg.org/gcrypt/alpha/gnupg/
22
23 You need at least GpgSM 1.9.6.
24
25 If configure can't find the `gpgsm' binary in your path, you can
26 specify the location with the --with-gpgsm=/path/to/gpgsm argument to
27 configure.
28
29 For building the CVS version of GPGME please see the file README.CVS
30 for more information.
31
32 For information how to use the library you can read the info manual,
33 which is also a reference book, in the doc/ directory.  The programs
34 in the tests/gpg/ directory may also prove useful.
35
36 Please subscribe to the gnupg-devel@gnupg.org mailing list if you want
37 to do serious work.