doc: python bindings howto
[gpgme.git] / configure.ac
index 6859357..c6c6dc8 100644 (file)
@@ -29,7 +29,7 @@ min_automake_version="1.14"
 # for the LT versions.
 m4_define(mym4_version_major, [1])
 m4_define(mym4_version_minor, [10])
-m4_define(mym4_version_micro, [0])
+m4_define(mym4_version_micro, [1])
 
 # Below is m4 magic to extract and compute the revision number, the
 # decimalized short revision number, a beta version string, and a flag
@@ -55,28 +55,28 @@ AC_INIT([gpgme],[mym4_full_version],[http://bugs.gnupg.org])
 #   (Interfaces added:                 AGE++)
 #   (Interfaces removed/changed:       AGE=0)
 #
-LIBGPGME_LT_CURRENT=29
-LIBGPGME_LT_AGE=18
+LIBGPGME_LT_CURRENT=30
+LIBGPGME_LT_AGE=19
 LIBGPGME_LT_REVISION=0
 
 # If there is an ABI break in gpgmepp or qgpgme also bump the
 # version in IMPORTED_LOCATION in the GpgmeppConfig-w32.cmake.in.in
 
-LIBGPGMEPP_LT_CURRENT=10
-LIBGPGMEPP_LT_AGE=4
+LIBGPGMEPP_LT_CURRENT=11
+LIBGPGMEPP_LT_AGE=5
 LIBGPGMEPP_LT_REVISION=0
 
-LIBQGPGME_LT_CURRENT=9
-LIBQGPGME_LT_AGE=2
+LIBQGPGME_LT_CURRENT=10
+LIBQGPGME_LT_AGE=3
 LIBQGPGME_LT_REVISION=0
 
 # If the API is changed in an incompatible way: increment the next counter.
 GPGME_CONFIG_API_VERSION=1
 ##############################################
 
-NEED_GPG_ERROR_VERSION=1.17
+NEED_GPG_ERROR_VERSION=1.24
 NEED_LIBASSUAN_API=2
-NEED_LIBASSUAN_VERSION=2.0.2
+NEED_LIBASSUAN_VERSION=2.4.2
 
 
 PACKAGE=$PACKAGE_NAME
@@ -280,7 +280,7 @@ if test x$fixed_search_path != x ; then
 fi
 
 
-# Note: You need to declare all possible langauges also in
+# Note: You need to declare all possible languages also in
 #       lang/Makefile.am's DIST_SUBDIRS.
 AC_ARG_ENABLE([languages],
               AC_HELP_STRING([--enable-languages=languages],
@@ -336,7 +336,7 @@ fi
 # Check that if qt is enabled cpp also is enabled
 LIST_MEMBER("qt", $enabled_languages)
 if test "$found" = "1"; then
-    # We need to ensure that in the langauge order qt comes after cpp
+    # We need to ensure that in the language order qt comes after cpp
     # so we remove qt first and explicitly add it as last list member.
     enabled_languages=$(echo $enabled_languages | sed 's/qt//')
     LIST_MEMBER("cpp", $enabled_languages)
@@ -656,7 +656,7 @@ fi
 # Try to find a thread-safe version of getenv().
 have_thread_safe_getenv=no
 jm_GLIBC21
-if test $GLIBC21 = yes; then
+if test $GLIBC21 = yes -o $have_w32_system = yes; then
   have_thread_safe_getenv=yes
 fi
 if test $have_thread_safe_getenv = yes; then