core: New global flag "require-gnupg".
authorWerner Koch <wk@gnupg.org>
Tue, 16 Aug 2016 16:53:42 +0000 (18:53 +0200)
committerWerner Koch <wk@gnupg.org>
Tue, 16 Aug 2016 16:53:42 +0000 (18:53 +0200)
commit8c09dd9989bcd434a8cb5997770cb8414b96bd5c
tree165b40484f5182676f32356b2f6b26c81723a2ca
parentb7b0e7b5bfefd51c8092ea54f262b18aebf78128
core: New global flag "require-gnupg".

* src/gpgme.c (gpgme_set_global_flag): Add flag.
* src/engine.c (engine_minimal_version): New variable.
(_gpgme_set_engine_minimal_version): New function.
(gpgme_get_engine_info): Check that flag.

* tests/run-keylist.c (main): New option --require-gnupg.

Signed-off-by: Werner Koch <wk@gnupg.org>
NEWS
doc/gpgme.texi
src/engine.c
src/engine.h
src/gpgme.c
tests/run-keylist.c