src: Fix dummy engine versions.
authorJustus Winter <justus@g10code.com>
Thu, 28 Jul 2016 15:45:53 +0000 (17:45 +0200)
committerJustus Winter <justus@g10code.com>
Thu, 28 Jul 2016 15:50:07 +0000 (17:50 +0200)
commitb9e6eacd06ffeb36854c208aa4325cff3e3dfbbe
treea58bc92f31f2d0396bf6a14464255aa947a528d9
parent2ff58fcbd5c060dac3a7feec478819d2c5a164ec
src: Fix dummy engine versions.

Previously, 'gpgme_engine_check_version' failed for these protocols
because the version parser failed to parse the dummy versions.

* src/engine-assuan.c (llass_get_version): Use a version triple that
the parser can understand.
(llass_get_req_version): Likewise.
* src/engine-spawn.c (engspawn_get_version): Likewise.
(engspawn_get_req_version): Likewise.
* src/engine-uiserver.c (uiserver_get_version): Likewise.
(uiserver_get_req_version): Likewise.

Signed-off-by: Justus Winter <justus@g10code.com>
src/engine-assuan.c
src/engine-spawn.c
src/engine-uiserver.c