qt, cpp: Fix versioning in cmake config and header
authorAndre Heinecke <aheinecke@intevation.de>
Wed, 2 Nov 2016 13:43:44 +0000 (14:43 +0100)
committerAndre Heinecke <aheinecke@intevation.de>
Wed, 2 Nov 2016 13:43:44 +0000 (14:43 +0100)
commitbf9aa0ccf7b0165aa3a1af2bdb18daca7c02ce74
tree42c906748e1764b0335f89ac73ed808d6be49a40
parentb5c4d56cfdcafade3467be100fca6f1c89ecab73
qt, cpp: Fix versioning in cmake config and header

* configure.ac (VERSION_MAJOR, VERSION_MINOR, VERSION_MICRO): New
subst variables for the version header.
* lang/cpp/src/GpgmeppConfigVersion.cmake.in,
lang/cpp/src/gpgmepp_version.h.in,
lang/qt/src/QGpgmeConfigVersion.cmake.in,
lang/qt/src/qgpgme_version.h.in: Use new variables.

--
Using the LT_* variables was just wrong. Reporting the
package version also makes more sense then the library version.
Having different versions might make ABI breaks more visible
by increasing the major version number, but to have different
versions in the same package is too confusing imo and gpgme
uses a versioning that is unrelated to the library version number.
configure.ac
lang/cpp/src/GpgmeppConfigVersion.cmake.in
lang/cpp/src/gpgmepp_version.h.in
lang/qt/src/QGpgmeConfigVersion.cmake.in
lang/qt/src/qgpgme_version.h.in