python: Improve python packaging.
authorJustus Winter <justus@g10code.com>
Tue, 12 Jul 2016 14:20:35 +0000 (16:20 +0200)
committerJustus Winter <justus@g10code.com>
Tue, 12 Jul 2016 16:34:12 +0000 (18:34 +0200)
* lang/python/Makefile.am: Sign source releases, and upload them.
* lang/python/setup.py.in: Add categories.

Signed-off-by: Justus Winter <justus@g10code.com>
lang/python/Makefile.am
lang/python/setup.py.in

index eecc7d4..0ac1dd0 100644 (file)
@@ -46,11 +46,17 @@ all-local: copystamp
        CFLAGS="$(CFLAGS) -I$(top_srcdir)" \
          $(PYTHON) setup.py build --verbose
 
-dist/pyme3-$(VERSION).tar.gz: copystamp
+dist/pyme3-$(VERSION).tar.gz dist/pyme3-$(VERSION).tar.gz.asc: copystamp
        CFLAGS="$(CFLAGS) -I$(top_srcdir)" \
          $(PYTHON) setup.py sdist --verbose
+       gpg2 --detach-sign --armor dist/pyme3-$(VERSION).tar.gz
 
-sdist: dist/pyme3-$(VERSION).tar.gz
+.PHONY: sdist
+sdist: dist/pyme3-$(VERSION).tar.gz dist/pyme3-$(VERSION).tar.gz.asc
+
+.PHONY: upload
+upload: dist/pyme3-$(VERSION).tar.gz dist/pyme3-$(VERSION).tar.gz.asc
+       twine upload $^
 
 CLEANFILES = gpgme.h errors.i gpgme_wrap.c pyme/pygpgme.py \
          copystamp
index 4667a9d..787d6a3 100755 (executable)
@@ -147,11 +147,28 @@ setup(name="pyme3",
       cmdclass={'build': BuildExtFirstHack},
       version="@VERSION@",
       description='Python bindings for GPGME GnuPG cryptography library',
+      # XXX add a long description
+      #long_description=long_description,
       author='The GnuPG hackers',
       author_email='gnupg-devel@gnupg.org',
       url='https://www.gnupg.org',
       ext_modules=[swige],
       packages = ['pyme', 'pyme.constants', 'pyme.constants.data',
                   'pyme.constants.keylist', 'pyme.constants.sig'],
-      license="LGPL2.1+ (the library), GPL2+ (tests and examples)"
+      license="LGPL2.1+ (the library), GPL2+ (tests and examples)",
+      classifiers=[
+          'Development Status :: 4 - Beta',
+          'Intended Audience :: Developers',
+          'Topic :: Software Development :: Build Tools',
+          'License :: OSI Approved :: GNU Lesser General Public License v2 or later (LGPLv2+)',
+          'Programming Language :: Python :: 3',
+          'Programming Language :: Python :: 3 :: Only',
+          'Programming Language :: Python :: 3.4',
+          'Programming Language :: Python :: 3.5',
+          'Programming Language :: Python :: 3.6',
+          'Operating System :: POSIX',
+          'Operating System :: Microsoft :: Windows',
+          'Topic :: Communications :: Email',
+          'Topic :: Security :: Cryptography',
+      ],
 )