Release 1.13.1 gpgme-1.13.1
authorWerner Koch <wk@gnupg.org>
Thu, 13 Jun 2019 07:00:38 +0000 (09:00 +0200)
committerWerner Koch <wk@gnupg.org>
Thu, 13 Jun 2019 13:18:38 +0000 (15:18 +0200)
* configure.ac: Bump LT versions to c=C33/A22/R1 cpp=C16/A10/R0
qt=C10/A3/R4.

Signed-off-by: Werner Koch <wk@gnupg.org>
NEWS
configure.ac

diff --git a/NEWS b/NEWS
index 72de591..9a7eac0 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,34 +1,34 @@
-Noteworthy changes in version 1.13.1 (unreleased)
+Noteworthy changes in version 1.13.1 (2019-06-13)
 -------------------------------------------------
 
- * Python: Fix DecryptionError Exception.  [#4478]
+ * cpp: gpgme_set_global_flag is now wrapped.  [#4471]
 
- * Python: No longer raises BadSignatures from
-   decrypt(verify=True).  [#4276]
+ * w32: Improved handling of unicode install paths.  [#4453]
 
- * cpp: gpgme_set_global_flag is now wrapped.
-   [#4471]
+ * w32: The gpgme_io_spawn error message is now only shown once. [#4453]
 
- * Fixed a crash introduced in 1.13.0 when working
-   with S/MIME.  [#4456]
+ * Fixed a crash introduced in 1.13.0 when working with S/MIME. [#4556]
 
- * w32: Improved handling of unicode install paths.
-   [#4453]
+ * w32: Fixed format string errors introduced in 1.13.0 that could
+   cause crashes.  [#4440]
 
- * w32: The gpgme_io_spawn error message is now
-   only shown once.  [#4453]
+ * w32: Fixed an error in the new diagnostic gpgsm support introduced
+   in 1.13.0 that caused crashes in low fd scenarios.  [#4439]
 
- * w32: Fixed format string errors introduced in
-   1.13.0 that could cause crashes.  [#4440]
+ * python: Fixed a DecryptionError Exception.  [#4478]
 
- * w32: Fixed an error in the new diagnostic
-   gpgsm support introduced in 1.13.0 that caused
-   crashes in low fd scenarios.  [#4439]
+ * python: No longer raises BadSignatures from decrypt(verify=True).
+   [#4276]
 
  * Interface changes relative to the 1.13.0 release:
  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
  cpp: setGlobalFlag                         NEW.
 
+ [c=C33/A22/R1 cpp=C16/A10/R0 qt=C10/A3/R4]
+
+ Release-info: https://dev.gnupg.org/T4551
+
+
 Noteworthy changes in version 1.13.0 (2019-03-26)
 -------------------------------------------------
 
index 9c6767f..7bc0604 100644 (file)
@@ -53,18 +53,18 @@ AC_INIT([mym4_package],[mym4_version], [https://bugs.gnupg.org])
 #
 LIBGPGME_LT_CURRENT=33
 LIBGPGME_LT_AGE=22
-LIBGPGME_LT_REVISION=0
+LIBGPGME_LT_REVISION=1
 
 # If there is an ABI break in gpgmepp or qgpgme also bump the
 # version in IMPORTED_LOCATION in the GpgmeppConfig-w32.cmake.in.in
 
-LIBGPGMEPP_LT_CURRENT=15
-LIBGPGMEPP_LT_AGE=9
+LIBGPGMEPP_LT_CURRENT=16
+LIBGPGMEPP_LT_AGE=10
 LIBGPGMEPP_LT_REVISION=0
 
 LIBQGPGME_LT_CURRENT=10
 LIBQGPGME_LT_AGE=3
-LIBQGPGME_LT_REVISION=3
+LIBQGPGME_LT_REVISION=4
 ################################################
 
 AC_SUBST(LIBGPGME_LT_CURRENT)