Adjust requirement for GpgSM version according to configure.ac.