* global.c (gcry_control): Add commands
[libgcrypt.git] / scripts / autogen.sh
1 #!/bin/sh
2 # Run this to generate all the initial makefiles, etc.
3
4 PGM=LIBGCRYPT
5
6 autoconf_vers=2.52
7 automake_vers=1.5
8 aclocal_vers=1.5
9 libtool_vers=1.4
10
11 DIE=no
12 if test "$1" = "--build-w32"; then
13     tsdir=$(cd `dirname $0`; cd ..; pwd)
14     shift
15     host=i386--mingw32
16     if [ ! -f $tsdir/scripts/config.guess ]; then
17         echo "$tsdir/scripts/config.guess not found" >&2
18         exit 1
19     fi
20     build=`$tsdir/scripts/config.guess`
21         
22     if ! mingw32 --version >/dev/null; then
23         echo "We need at least version 0.3 of MingW32/CPD" >&2
24         exit 1
25     fi
26
27     if [ -f "$tsdir/config.h" ]; then
28         if grep HAVE_DOSISH_SYSTEM config.h | grep undef >/dev/null; then
29             echo "Pease run a 'make distclean' first" >&2
30             exit 1
31         fi
32     fi
33
34     crossbindir=`mingw32 --install-dir`/bin
35     CC=`mingw32 --get-path gcc`
36     CPP=`mingw32 --get-path cpp`
37     AR=`mingw32 --get-path ar`
38     RANLIB=`mingw32 --get-path ranlib`
39     export CC CPP AR RANLIB 
40
41     disable_foo_tests=""
42     if [ -n "$lib_config_files" ]; then
43         for i in $lib_config_files; do
44             j=`echo $i | tr '[a-z-]' '[A-Z_]'`
45             eval "$j=${crossbindir}/$i"
46             export $j
47             disable_foo_tests="$disable_foo_tests --disable-`echo $i| \
48                            sed 's,-config$,,'`-test"
49             if [ ! -f "${crossbindir}/$i" ]; then                   
50                 echo "$i not installed for MingW32" >&2
51                 DIE=yes
52             fi
53         done
54     fi
55     [ $DIE = yes ] && exit 1
56
57     $tsdir/configure --build=${build} --host=${host} \
58                 ${disable_foo_tests} $*
59     exit $?
60 fi
61
62
63
64 if (autoconf --version) < /dev/null > /dev/null 2>&1 ; then
65     if (autoconf --version | awk 'NR==1 { if( $3 >= '$autoconf_vers') \
66                                exit 1; exit 0; }');
67     then
68        echo "**Error**: "\`autoconf\'" is too old."
69        echo '           (version ' $autoconf_vers ' or newer is required)'
70        DIE="yes"
71     fi
72 else
73     echo
74     echo "**Error**: You must have "\`autoconf\'" installed to compile $PGM."
75     echo '           (version ' $autoconf_vers ' or newer is required)'
76     DIE="yes"
77 fi
78
79 if (automake --version) < /dev/null > /dev/null 2>&1 ; then
80   if (automake --version | awk 'NR==1 { if( $4 >= '$automake_vers') \
81                              exit 1; exit 0; }');
82      then
83      echo "**Error**: "\`automake\'" is too old."
84      echo '           (version ' $automake_vers ' or newer is required)'
85      DIE="yes"
86   fi
87   if (aclocal --version) < /dev/null > /dev/null 2>&1; then
88     if (aclocal --version | awk 'NR==1 { if( $4 >= '$aclocal_vers' ) \
89                                                 exit 1; exit 0; }' );
90     then
91       echo "**Error**: "\`aclocal\'" is too old."
92       echo '           (version ' $aclocal_vers ' or newer is required)'
93       DIE="yes"
94     fi
95   else
96     echo
97     echo "**Error**: Missing "\`aclocal\'".  The version of "\`automake\'
98     echo "           installed doesn't appear recent enough."
99     DIE="yes"
100   fi
101 else
102     echo
103     echo "**Error**: You must have "\`automake\'" installed to compile $PGM."
104     echo '           (version ' $automake_vers ' or newer is required)'
105     DIE="yes"
106 fi
107
108
109 #if (gettext --version </dev/null 2>/dev/null | awk 'NR==1 { split($4,A,"\."); \
110 #    X=10000*A[1]+100*A[2]+A[3]; echo X; if( X >= 1035 ) exit 1; exit 0}')
111 #    then
112 #    echo "**Error**: You must have "\`gettext\'" installed to compile $PGM."
113 #    echo '           (version 0.10.35 or newer is required; get'
114 #    echo '            ftp://alpha.gnu.org/gnu/gettext-0.10.35.tar.gz'
115 #    echo '            or install the latest Debian package)'
116 #    DIE="yes"
117 #fi
118
119
120 if (libtool --version) < /dev/null > /dev/null 2>&1 ; then
121     if (libtool --version | awk 'NR==1 { if( $4 >= '$libtool_vers') \
122                                exit 1; exit 0; }');
123     then
124        echo "**Error**: "\`libtool\'" is too old."
125        echo '           (version ' $libtool_vers ' or newer is required)'
126        DIE="yes"
127     fi
128 else
129     echo
130     echo "**Error**: You must have "\`libtool\'" installed to compile $PGM."
131     echo '           (version ' $libtool_vers ' or newer is required)'
132     DIE="yes"
133 fi
134
135
136 if test "$DIE" = "yes"; then
137     exit 1
138 fi
139
140 #echo "Running gettextize...  Ignore non-fatal messages."
141 #echo "no" | gettextize --force
142 echo "Running libtoolize...  Ignore non-fatal messages."
143 echo "no" | libtoolize
144
145
146 echo "Running aclocal..."
147 aclocal
148 echo "Running autoheader..."
149 autoheader
150 echo "Running automake --gnu ..."
151 automake --gnu;
152 echo "Running autoconf..."
153 autoconf
154
155 echo "You can now run \"./configure\" and then \"make\"."
156
157